Not all Countries appear in Location Block

With version 151 and after forcing the update using “location update”, not all countries appear in the Location Block.

[root@bs ~]# location version
Fri, 30 Oct 2020 04:27:17 GMT
[root@bs ~]#

I have tried several IPFires and the same thing happens.

It happens to someone else?.


This is a bug ( ).

If there are other users experiencing this, it would be helpful to know the parameters core-version(32/64Bit) and memory size.

1 Like

Hello @bbitsch.

Thanks for your quick response.

The data of two machines are:

And another that is of different hardware:

I have a PCEngines (I have not dared to do more) that apparently is not affected:


And other with other architecture (ARM):

Is a NanoPI R1S.

Best Regards.

thx for your fast reply.

If I see it right, all systems use the 32Bit versions.
Maybe this is a hint for a possible solution.

Guau @bbitsch, your patch works OK!!!.

I try to update to 152 core and this not was solution. In 152 core, with your solution in Bugzilla, works Ok.


Only thing, the missing countries, when appearing, are not marked according to the previous configuration.

Just as a curiosity.


Don’t know your previous config, thus the picture says nothing. :wink:

Maybe the broken web page manipulated the settings somehow. But it should be possible to correct these settings. The web page shows the contents of the settings file ( don’t know how it is named exactly ), editing is possible, a ‘save’ rewrites the settings file and reconstructs the FW.


here my Rapberry Pi 3 B
with same problem.
The workaround is OK


I am seeing in “Location Block” but also in the “firewall rules” section…
As you can see I cannot perform any modification as the UI is partially rendered

IPFire version IPFire 2.25 (armv5tel) - core152
Pakfire version 2.25-armv5tel
Kernel version Linux ipfire.cottageNet 4.14.198-ipfire-multi #1 SMP Sat Nov 14 16:40:58 GMT 2020 armv7l Allwinner sun8i Family GNU/Linux

Try here

Hi all,

first: Core Update 153 is available for testing, including a fix for this.

Second, in order to avoid duplicates, I will close this topic. Please head over to this one in case you want to leave comments on this issue:

Thanks, and best regards,
Peter Müller

1 Like