No sftp connection to ipfire

with ssh -p222 root @ ipfire and scp -P … the connection from the client console works. But not an sftp connection from the client to dolphin?

Although I do not use any keys to connect, I log in directly with the password, but I still have those keys on the GUI under SSH access (I removed the fingerprints in the picture). What strikes me are the two keys with 256 bits, are they still valid at all, or am I on the completely different track.

Why does the sftp via dolphin no longer work?

Not the same thing -> are you trying to connect to the same appliance? Maybe IPFire in your current configuration is not hosting sFTP.

o yes, thanks, but sftp is based on ssh, scp too. That’s why I mentioned that it worked without a problem in the terminal. Even this works in the sftp -P 222 root@ipfire console. After I enter my password I get the sftp> Promt

So I’m assuming that my IpFire can do something with sftp, but as I said via Dolphin not. I just don’t find the error devil.

Maybe dolphin is refusing a non-valid certificate? Non-valid = chain of CA and certification not verified…

would be possible, how can I check or renew it.

sorry wrong chat

Maybe you have the same issue I had:

at least something similar, with the small difference that I can implement the following connections via the console (terminal):

ssh -P 222 root@ipfire
scp -P 222 ~/test.txt root@ipfire/~
sftp -P 222 root@ipfire

What is not possible is to get to the ipfire via Dolpin or FileZilla!

I just tested with FileZilla on my Windows system.
No problem.
There must be some incorrent config on your side.

yes it can be that any setting in a config file is the cause, but which one?

Is there somewhere the defalut settings to look up or to compare

Do get any error messages?

Connection refused when Krusader

Much silence in the forest

Yes, but from your side also.
Some whistling about your configuration could help the error “hunters”.

and what configurations / files are we talking about

do you have an example or default configuration (s) for me to compare …

so dear ones, finally a light on the eternally long tunnel. Come back via sftp on IpFire.

My solution was to let go of sudo apt purge openssh* on the client.