No reboot after core update


For several months (and therefore several updates), I have been facing a restart problem following new updates on one of my firewalls:

I trigger a stable update from the GUI, and when I reboot to apply it I have the following messages but no reboot:

Bringing down the loopback interface…
Remount root readonly…
Prepare for reboot…

…then nothing !

I have to go there, physically turn off and restart the firewall

Which is problematic because the firewall is remote and the client no longer has access to the Internet until the firewall restarts.

Usually this is a bios/uEFI problem.

You can try to switch the reset method via kernel commandline

or update the bios/uEFI firmware.


Hello @arne_f ,

I just added reboot=b in /etc/default/grub and regenerate the grub config as shown.

I’ll let you know when I’ve done the last stable update and rebooted (in my case CU 173 to 174) !

Thanks you very much !

Hi @arne_f

after updating my firewall (CU 173 to 174 stable), reboot still doesn’t work

Then :
Replaced reboot=b with reboot=k
grub regeneration
Changing CU version in /opt/pakfire/db/core/mine (172)
pakfire upgrade then reboot…

It works, IPFire restarts perfectly !

It fixed, thanks again !



after CU 175 update by the standard method (Pakfire > update…), IPFire always restarts well, happiness ! Problem solved for me !

Thanks @arne_f !

1 Like