No OpenVPN tunnel on MiFi

I’m currently using a MiFi device as my wired internet is broken :frowning:
It’s connected to the IPFire box via USB using the QMI control method.

The MiFi box (TP-Link M7350) is reporting its IP Address as 10.205.x.x, in the private range. The IP Address registered through Dynamic DNS is 78.86.x.x (and it’s being updated every 5 minutes).

Based on this evidence, I assume my ISP is using NAT to connect more mobile devices to the same, limited set of public IP Addresses it has available.

As a result, I can’t connect to IPFire and to my servers from the outside using OpenVPN.

Any advice if it’s possible to fix this? Should I just switch mobile service supplier?

I think your choices are to ask the current cell company for a public IP (non-NAT IP) or change cell companies.

Did you want to try connecting outward from the IPFire side to the other side. Maybe an outward net-to-net OpenVPN? (I am not the expert on this but I’ve seen others suggest it)

Are you able to setup a OVPN server in the cloud?

Thanks both. I feared this.

I’ve checked our other cell phones (we have 3 providers in the family) and they’ve all switched to the private IP Address + NAT solution (for the cheap services) so the option there is pay a lot more money for the public IP Address.

I can see I’ll have to start what I’ve been deferring (it’s a lot of work setting up right) - getting a cloud server setup and secure files storage there. A little cloud server for VPN connections will be a stepping stone to the bigger job of protecting us against total loss in the event of fire etc. Local backups are so last century. :slight_smile:

I think I’ll do the simple thing (I’m familiar with the tech) - run IPFire on that server acting as a gateway & proxy.

When you figure this out please post.

I have the same issue with a CGNAT (it has a different private IP range than what you see). See: