No DNS resolving on RED

I first failed to upgrade from core 142 to 144. ‘pakfire update’ responded with '‘Giving up: …’ and pakfire logs stated ’ ‘DOWNLOAD INFO: HTTP-Status-Code: 500 - 500
Can’t connect to (Name or service not known)’. Pinging from RED failed but pinging responded o.k. I am running ipfire (red/green/blue/orange) for quite some time now without major interruption and unchanged configuration
After I have added ‘nameserver’ to /etc/resolv.conf everything worked again. I am not sure if this is the right way to do and would appreciate some advise.

Hello Bernd,

As far as I know the DNS System has been reorganized in the meanwhile. Have you entered the DNS Servers in “Network”->“Domain Name System” ?



Hi Steffen,

yes, I have, and
DNS resolution works without the added /etc/resolv.conf entries for all but RED.

Best Regards

I just saw my problem might be related to this one

The temporary work around to proceed with the upgrade from 142 to 144 is to add the DNS server IP to /etc/resolv.conf like I have done. Seems that etc/resolv.conf will be regenerated at reboot.

Let’s see if the upgrade has solved the issue (I can only reboot tonight).

The upgrade didn’t fix the issue. I will reply here as the topic reflects my problem.


could you please post:

  • a screenshot of your DNS configuration
  • any lines in /var/log/messages containing unbound
  • the output of ping

Thanks, and best regards,
Peter Müller

Hi Peter,

DNS config and messages are attached.
ping -c 5 returns:

PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=58 time=12.7 ms
64 bytes from icmp_seq=2 ttl=58 time=30.3 ms
64 bytes from icmp_seq=3 ttl=58 time=29.8 ms
64 bytes from icmp_seq=4 ttl=58 time=14.5 ms
64 bytes from icmp_seq=5 ttl=58 time=19.9 ms

— ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 4006ms
rtt min/avg/max/mdev = 12.736/21.491/30.361/7.446 ms (54.8 KB)

Thanks in advance

I freshly installed ipfire today and still face the same problem.


sorry for the delay.

Your problem is apparently caused by a syntax error in /etc/unbound/hosts.conf:

Apr 30 03:31:40 ipfire unbound: [2177:0] error: error parsing local-data at 20 'server1.myipfire 60 IN A': Syntax error, could not parse the RR's type

Would you mind posting the content of that file here so we can see what is going wrong?

Thanks, and best regards,
Peter Müller

Thanks Peter. It is working now, but I don’t know why.

I freshly installed ipfire and configured as described earlier. DNS did not resolve on RED and I was therefore not able to install any addons or configure IPS. So I added the nameserver IP in /etc/resolv.conf and then was able to finish the installation and configuration. After reboot tonight /etc/resolv.conf was regenerated as expected without my added nameserver IP and DNS is working correctly on RED now.

There still seems to be a bug but at least a workaround (in my case) exists. Hope this might help others, too.

Thanks again and
Best Regards


well, I am glad things work by now, but it certainly is not satisfying to
reinstall and modifying /etc/resolv.conf. :expressionless:

Anyway, if you have any more clue about it’s root cause, please open up a
ticket at Thank you.

Best regards,
Peter Müller