No boot on Raspberry Pi 3B

I’m trying to set up IpFire on a Raspberry Pi 3B v1.2. I followed the instructions from - Raspberry Pi 3 Model B. But it does not boot at all. Blank screen, no green led. The board is of course functionnal (tested on Raspbian). Any idea to solve that will be highly appreciated :wink:



Hi Pierre - If there is absolutely nothing on the console / monitor screen I would guess the SD card didn’t burn correctly (or is bad).

I use Etcher to burn SD cards and it is very reliable! Just make sure you download the correct IPFire image.

Hi Jon, thanks for getting back to me. The SD card is OK. I burn it with a Raspbian to test it and the PI itself. I reburnt the card using the lastest version of both Etcher and IpFire - ARM. Absolutly nothing on screen / keyboard. At power up the grenn LED of the PI flashes once and then nothing.

what file did you download (please be very specific)?

And where did you download the file from?

EDIT: I downloaded the current IPFire 2.25 - Core Update 156 ARM version. Burned it to SD via Etcher and since I am using HDMI I edited the uENV.txt file and change SERIAL-CONSOLE=ON to OFF.

I have an RPi 3B+ (not the RPi 3B) and that device booted within a moment or two. I was able to run The IPfire Setup fine.

Both files have been downloaded from - How-to flash ARM image to SD Card?

The flash image i used is the one provided in this URL : ipfire-2.25.2gb-ext4.armv5tel-full-core156.img.xz

and how did you burn the ipfire-2.25.2gb-ext4.armv5tel-full-core156.img.xz file to the SD card?

Hi guys, I am having similar issue with my Raspberry Pi 3 b.

I have downloaded the arm flash image from:

I have used both etcher and rufus to flash to the sdcard. And have burnt the image at least twice with each program.

But every time the pi will hang at the rainbow splash screen and not progress.

I have tested the card in two different raspberry pi’s and booted both pi’s into kodi with a different card to test that the pi’s are working.

Hi @nuxsfm and @tyz38

Can you confirm if you are using the serial console connection for installing IPFire or the HDMI connection.

Serial console is the default from the flashing of the image but worth checking that the config.txt file has enable_uart=1 at the end. If not then it needs to be added.

If using HDMI did you edit the uENV.txt file and change SERIAL-CONSOLE=ON to SERIAL-CONSOLE=OFF

Thanks for the reply, yes I am using HDMI + Keyboard. And edited the uENV.txt file. After following the instructions on the ipfire site, i then watched some youtube videos as well to make sure I hadn’t skipped over anything (I had not).

From what i have been able to google I am getting some kind of kernal error, that isnt allowing the raspberry pi to boot. Although, this could be completely incorrect as I dont have the personal knowledge to test this theory.

Edit: I realise I am not supplying much information as to what is causing the issue and making it very hard to trouble shoot. But I am not getting much info to actually work with, so if there is something I can do to provide more info to help please let me know.

Ususally you first get a square with rainbow colors. (firmware)
this firmware starts “Das U-Boot” that prints some hardware informations and then boot IPFire,
Also from a misconfigured card (serial console on) this should run until a screen with 4 penguins.

So this is no kernel problem because it looks like u-boot not start.
For me this looks like a corrupted card.

I grabbed a RPi 3B (instead of the 3B+), burned a SD Card and booted up an ipfire-2.25.2gb-ext4.armv5tel-full-core156.img.xz.

All booted and worked as it should.

1 Like

What do you mean by "how did i " @jon? There si no flashing option in etcher.

Hi @bonnietwin. I can’t change anything as it’s not booting at all.

Hi @nuxsfm

On the system that you flashed the card on you should be able to see what files are on the card and edit the required ones.

Thanks @bonnietwin. Did it but nothing changes. Still not booting. I’m not surprised. It would have at least booted even if nothing appears on screen.

Pierre -

Plug the SD card into your home computer.

Do you see a list of files?

I have a Mac and this is what I see. The Untitled device is the SD Card:

Screen Shot 2021-05-27 at 10.58.54 AM

If I open Untitled I see:

Do you see the same?

1 Like

hi @jon, yes i do. I plugged the card on another linux machine. Got a few ones :wink:

Everything seems to be there. 3 partitions & so on. It’s a hardware architecture pb i think. It tries to boot and then nothing. I’m thinking of cross-compiling my own version. But O boy! How it bores me to do it… I did that so many times with LFS and i have so few free time to do it… :weary:

And no log of course as it does not boot^^

It may be that the SD card is too small. It this a 2 GB card?

I usually use 8 GB SD cards…

EDIT: this is what I see when I mount the SD card on another RPi:

pi@RPi4B:~ $ sudo fdisk -l /dev/sda

Disk /dev/sda: 14.5 GiB, 15523119104 bytes, 30318592 sectors
Disk model: SD  Transcend   
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x3d0bb1d9

Device     Boot  Start      End  Sectors  Size Id Type
/dev/sda1  *      8192   262143   253952  124M  c W95 FAT32 (LBA)
/dev/sda2         2048     2048        1  512B  0 Empty
/dev/sda3       262144 30318591 30056448 14.3G 83 Linux

Partition table entries are not in disk order.
pi@RPi4B:~ $ 

EDIT2: I am curious - why is this so small?

1 Like

Your’re Lynx Eyed @jon :slight_smile: That’s a good question. It’s a 8Go card… Hmmm, got to investigate that

You have answered this yourself several times. You can not boot. So it is at the same size as after flashing. So the size looks like it should after flashing. After expanding (booting) this should change.

1 Like