New user, successful installation on laptop, web admin panel doesn't respond from pc

Hi! I’m very new user of ipfire and I’m really bad in network management. I have to use local firewall with openvpn inside for my work (development).
What I have now:

  1. consumer modem
  2. old laptop with realtek network card and usb network card as second card (tp-link ue-200)
  3. desktop pc

I had installed ipfire successfully with this tutorial: wiki.ipfire.org - Step 5: Network Setup
I entered the same addresses and values in all input fields. However, after it I can’t access web admin panel via url ipfire.localdomain:444/ (or 192.168.1.1:444/) I really don’t know why
I tried to ping my consumer modem ip (192.168.0.1) from laptop with ipfire - it works. But when I try to ping laptop with ipfire from my desktop pc it doesn’t work.

Please, can someone help me with that? I can execute any commands with results but please write these commands to me, because I’m pretty bad in network. Thank you so much!

Did you try https://192.168.1.1:444/ (please note the s in https)

1 Like

Yes, I tried https://192.168.1.1:444/. I just missed https:// in my question because I can’t past many links as a new user. It doesn’t respond. I tried to ping 192.168.1.1 from my desktop pc and it’s not working too
Maybe I can provide some info from ipfire console?

If you type ifconfig in the console, it will list all interfaces. You can mask the red as probably it is public. We care about the green interface. You could post the contents of /var/ipfire/ethernet/settings

@pavlos ok, it’s done. Here is content from file /var/ipfire/ethernet/settings. I’m sorry for possible typos I had to type it from my laptop screen since I can’t access by ssh

CONFIG_TYPE=1
GREEN_DEV=green0
GREEN_MACADDR=b4:b0:24:be:50:61
GREEN_DESCRIPTION='"usb: TP-Link USB 10/100 LAN"'
GREEN_DRIVER=cdc_ether
RED_DEV=red0
RED_MACADDR=34:e6:d7:7d:4d:08
RED_DESCRIPTION='"pci: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast ethernet controller (rev 07)"'
RED_DRIVER=R8169
GREEN_ADDRESS=192.168.1.1
GREEN_NETMASK=255.255.255.0
GREEN_NETADDRESS=192.168.1.0
RED_DHCP_HOSTNAME=ipfire
RED_DHCP_FORCE_MTU=
RED_ADDRESS=0.0.0.0
RED_NETMASK=0.0.0.0
DEFAULT_GATEWAY=0.0.0.0
RED_TYPE=DHCP
RED_NETADDRESS=0.0.0.0

correct this line

DEFAULT_GATEWAY=192.168.1.1

and reboot.

After system comes up, login as root and type ifconfig, see the ip’s assigned for red & green.

You should be able to ping google.com or ping 8.8.8.8

2 Likes

@pavlos
It’s done. I changed this line to 192.168.1.1 and then reboot
Here is result of ifconfig command:

green0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.1  netmask 255.255.255.0  broadcast 0.0.0.0
        ether b4:b0:24:be:50:61  txqueuelen 1000  (Ethernet)
        RX packets 785  bytes 108826 (106.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 64  bytes 3824 (3.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 64  bytes 3824 (3.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

red0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 34:e6:d7:7d:4d:08  txqueuelen 1000  (Ethernet)
        RX packets 28  bytes 2580 (2.5 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

However, ping google.com or ping 8.8.8.8 doesn’t work from ipfire

so red0 did not pick up an ip even though it is configured dhcp?

1 Like

@pavlos looks like but I set up it as shown in the wiki:wiki.ipfire.org - Step 5: Network Setup

You setup is: consumer modem ---- red (laptop with ipfire) – green 192.168.1.1

I don’t know what this consumer modem is (in the US we use cable modem) and I don’t know if there is a setup on that modem to provide an ip (some modems need to be in bridge mode). I don’t want to know the red ip, it is public so mask it if you have to. From example, my public ip is 64.*

If you can run setup on the console again and verify that all steps follow what the wiki shows. Maybe someone else has ideas …

Hi !
The connection type must be know to properly setup the RED interface.

clidk on connection type.
in new page : https://wiki.ipfire.org/installation/red
click on : See Static for more information.
follow instructions.

Good day

Btw, you can obtain ip address from your box by plugging your client pc direct on your " consumer modem "

I don’t think that is correct.

DEFAULT_GATEWAY=0.0.0.0 applies to red0 and would be correct for red0 getting its address via DHCP. OP should change back to DEFAULT_GATEWAY=0.0.0.0

It’s possible that some firewall or network setting in the PC has the latter set to a different network address. OP could try booting a Live Linux on the PC - that should then get an address in the 192.168.1.0 network.

Hi @rodneyp

I compared his post with my system which is cablemodem – (red) – ipfire – (green) 10.0.0.1

[root@ipfire ~]# cat /var/ipfire/ethernet/settings 
CONFIG_TYPE=1
GREEN_DEV=green0
GREEN_MACADDR=00:19:b9:22:36:1b
GREEN_DESCRIPTION='"pci: Broadcom Inc. and subsidiaries NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)"'
GREEN_DRIVER=tg3
RED_DEV=red0
RED_MACADDR=00:1b:21:c5:ab:e7
RED_DESCRIPTION='"pci: Intel Corporation 82541PI Gigabit Ethernet Controller (rev 05)"'
RED_DRIVER=e1000
RED_DHCP_HOSTNAME=ipfire
RED_DHCP_FORCE_MTU=
RED_ADDRESS=0.0.0.0
RED_NETMASK=0.0.0.0
RED_TYPE=DHCP
RED_NETADDRESS=0.0.0.0
RED_BROADCAST=255.255.255.255
GREEN_ADDRESS=10.0.0.1
GREEN_NETMASK=255.255.255.0
GREEN_NETADDRESS=10.0.0.0
GREEN_BROADCAST=10.0.0.255
DEFAULT_GATEWAY=10.0.0.1
[root@ipfire ~]#

Completing the theme,
below are the results of the cat /var/ipfire/ethernet/settings command:
(on VM testing machine)

for dynamic IP for RED interface

obraz

[root@ipfire ~]# cat /var/ipfire/ethernet/settings
CONFIG_TYPE=1
GREEN_DEV=green0
GREEN_MACADDR=08:00:27:f6:00:e6
GREEN_DESCRIPTION='"pci: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)"'
GREEN_DRIVER=e1000
RED_DEV=red0
RED_MACADDR=08:00:27:47:bd:7f
RED_DESCRIPTION='"pci: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)"'
RED_DRIVER=e1000
RED_DHCP_HOSTNAME=ipfire
RED_DHCP_FORCE_MTU=
RED_ADDRESS=0.0.0.0
RED_NETMASK=0.0.0.0
DEFAULT_GATEWAY=0.0.0.0
RED_TYPE=DHCP
RED_NETADDRESS=0.0.0.0
GREEN_ADDRESS=10.0.11.99
GREEN_NETMASK=255.255.255.0
GREEN_NETADDRESS=10.0.11.0
[root@ipfire ~]#

for static IP for RED interface
obraz

[root@ipfire ~]# cat /var/ipfire/ethernet/settings
CONFIG_TYPE=1
GREEN_DEV=green0
GREEN_MACADDR=08:00:27:f6:00:e6
GREEN_DESCRIPTION='"pci: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)"'
GREEN_DRIVER=e1000
RED_DEV=red0
RED_MACADDR=08:00:27:47:bd:7f
RED_DESCRIPTION='"pci: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)"'
RED_DRIVER=e1000
RED_DHCP_HOSTNAME=ipfire
RED_DHCP_FORCE_MTU=
RED_ADDRESS=10.0.2.15
RED_NETMASK=255.255.255.0
DEFAULT_GATEWAY=10.0.2.1
RED_TYPE=STATIC
RED_NETADDRESS=10.0.2.0
GREEN_ADDRESS=10.0.11.99
GREEN_NETMASK=255.255.255.0
GREEN_NETADDRESS=10.0.11.0
[root@ipfire ~]#

It’s really strange but I think it was kind of software problem on my PC which was connected to green interface from IPfire. I’ve just reinstalled IPfire right now and I’ve got a request access for new network connection on my PC. In previous installation I didn’t notice such request notification. I’ve submitted it and now it works!
I’ve connected to a web ui successfully after that. So, thank you all for answers on my dummy question!