New on IPFire URL Filter not working correctly

Hi, im new using IPFire, im using it for a final grade work(Virtual machines), i complete the installation correctly(i think), this machine work as firewall for another server(Windows), IPFire network its GREEN+RED(Green in LAN and Red bridged with real machine to provide Internet).
Servers are on the same range IP, and windows get internet from RED and it works, but the URL Filter doesnt block any site, i dont know why doesnt work, proxy non transparent, DNS addreses for clients its RED, but filter do nothing.
I try too to put in the blacklist some sites but same, dont work, if anyone can help me please tell me, i can provide some screenshots if it is necesary.

Thanks you all and sorry for my bad eng.

Is the proxy configured in the broser on the client (manually or via wpad). This is needed in “non transparent” mode.


Nope, then if i change it to transparent, it should work auto without configuration? btw i will try to configure the proxy manually when i get home too

If the proxy is in transparent mode the URL Filter will only block HTTP sites. And not HTTPS sites.

If you place the proxy in non-transparent then the URL Filter will block both HTTP and HTTPS. But configuration is needed.

This is not an area that I understand so someone more skilled than me will need to assist you.

1 Like

Yesterday when i put proxy in not-transparent and i lost the conex(just cant reach any site), but i can still ping DNS GREEN, 2 DNS Google, for check the connection) sucessfully with client, but it can be because of non-transparent proxy then?

I see on other site that can be an error config with web ports 80, 443 but these ports are permitted i think.

Anyways when i can i will try these config to see if it works, but if it doesnt work i can share my config too here, thanks for your time.

You are mixing the protocols here. Ping is ICMP and is portless. HTTP(S) is TCP and uses port 80 and 443 respectivly. So even if you can ping outside servers it says nearly nothing about reaching these ports. I consider a transparent proxy superfluous nowadays as seemingly all sites use https. With a non transparent proxy your pc needs to be told the proxy address and port. Under Windows it’s in the internet settings for example.
However you should be able to reach the web sites even without going through the proxy. IPFire is not blocking forwarding connections from green to red by default (see bottom of page under “firewall options”). Sort that issue first before you dive further into the proxy/url filter issue.

1 Like