'network' command not found

Hi not sure if this is the right area to post. Newbie here and have setup my ipfire system with a vm running via qemu. I need to configure access to this VM to my LAN so that my Plexmediaserver is visible to the network.

I have tried using the commands like : network device list and network zone create but get a response > command not found. It appears that either I have a bad install or the wiki needs updating. Has anyone seen this before or know of a method to correct this?

I have all the adons installed and updated to core 167. My pc is an i3 with 12GB ram. And both interfaces are working as expected on red and green.

Hi @deanst

Welcome to the IPFire community.

Those commands are related to IPFire3.x which is still under development and therefore are not in IPFire2.x
Could you explain a bit more what you are trying to do. It is not clear to me if the plexmediaserver is in the vm on ipfire or is on a pc on your green network and which network you want the plexmediaserver to be visible to.


Hi Adolf, the plex is on lxle running in the vm. It is odd that a dev versions information should be on the wiki.
The plex server needs to be accessed on the green network only as I have no lneed to access it remotely.

I don’t see any problem with development stuff being in the wiki. It is under the Development entry in the wiki.
All the rest of the IPFire2.x stuff is in the other entries in the wiki.

I am not at all familiar with qemu. I have used virtualbox but not for a vm on IPFire but to setup a virtual IPFire with virtual pcs as my testbed for testing releases.

If you have set up your vm as per the wiki qemu page then it is in the orange zone. So then any pc on the green network will be able to access the plexserver on the orange network as that direction is accessible by default. See following link on default ruleset.

1 Like

Hi Adolf I will run setup to add orange network and test. Thank you

Looking at the wiki page for the installation of the qemu addon


It looks like after installing qemu you have to configure it with either a real unused nic on your system or with a virtual one if you don’t have a spare real nic. This real or virtual nic then has to be associated with a zone and the wiki page uses the orange zone for that.

If the wiki page above is not sufficient to help you get things working then other community members who actually use qemu will be better placed to help you further.

Good luck.

Hi Adolf, yes I have been following that wiki but seem to be confused as to the IP configuration. I run setup and set an IP for orange0 and this is where I get confused do I set the same IP in the guest on the qemu vm …

I will find the guys who are working on qemu in the community.

Thank you for all your help.

ps I have made it far enough to access my smb shares via the guest vm so its not too far off.

1 Like