NanoPI R1 green0: carrier off issue

How about guys?.

One question.

In one NanoPI R1 I have had a problem with the Green0 interface and the only way to temporarily solve it has been by turning the device off / on (removing the power supply).

It gives this error:

|11:27:04|kernel: |r8152 1-1:1.0 green0: carrier on|
|11:27:02|kernel: |r8152 1-1:1.0 green0: carrier off|
|11:27:00|kernel: |r8152 1-1:1.0 green0: carrier on|
|11:26:58|kernel: |r8152 1-1:1.0 green0: carrier off|
|10:40:02|kernel: |r8152 1-1:1.0 green0: carrier on|
|10:39:58|kernel: |r8152 1-1:1.0 green0: carrier off|

I have read something about it in: which says that it is an AutoNegotiated problem and that it can be temporarily solved by doing what it says. But I say …

How to make the NanoPI auto-configure itself by disabling AutoNegotiation?. I have tried this but I don’t know how to set it to do it at startup every time automatically.

ethtool -s green0 speed 100 duplex full autoneg off

Any hint would be appreciated.

Greetings to all and good weekend.

This could be a cat 5 cable issue. I have some cables with plugs that won’t stay fully inserted in a few sockets and the interface repeatedly reports disconnect followed by connect.

Managed switch with fixed negotiation parameter?
Edit: r8152 is 2.5G ethernet adapter. Am i wrong? edit Yes i am, 8152b should be 2.5GB

@roberto would you please try to use a more powerful power adapter? With bigger Ah capacity if possible. Only as test, of course.

Thanks guys for your quick reply.

The cable thing, it may be, in some cases it has happened to me. The problem is that I don’t have access to it to do as many tests as I want.

It supposedly has a 5V 3A power adapter. That should be enough, right? Well, the power adapter is Chinese, so I don’t know if it really gives 3A.

I’ve tried turning AutoNegotiation OFF and it seems to no longer give an error. I remember there were some Nokia OfficeConnect routers that got along very badly with AutoNegotiation when putting perimeter solutions and you had to force the speed and mode by hand.

Is there a way to put it so that at startup it is always with 100 full duplex and AutoNegotiated in OFF ?.

Thank you very much.