My IPFire wont boot anymore

Hello everyone,

My IPFire Eco Appliance let me down today.
I have two problems:

  1. The BIOS Battery seems broken
    Every Time i unplug the system from power, i need to setup the BIOS settings again

  2. I wont get past the initial entropy process. It starts and runs until 30/… and then the whole system reboot. Even manually speeding up the entropy process with keyboards wont help.

Are the two problems maybe related?

Reinstall IPFire wont help, too!

Best regards and i wish everyone a good start in 2021

Hi Hanz

I don’t think the two are related but I see different equipment act differently so… Try replacing the CMOS battery, go into the BIOS and make sure your settings are correct. Then try again. If you get the same behavior then burn a copy of MemTest onto a USB stick or CD/DVD or…whatever and boot to that. See if after running it one full pass it passes lol (no errors found).
Let me know if this doesn’t work please.


I think not because the battery of my eco is also empty and i have no problems with the entropy. Have you tried to reseat the RAM modules?


Where do i get these kind of batteries?
Read on amazon you need to be careful with the polarization on the plug, so you buy the right replacement.
Can i get the replacement parts in general, where i got the IPFire appliance?

Usually a CMOS battery is CR2032. Depending on the m/b, it could just be a round battery (silver colour) or in laptops there are two wires (red,black) with a connector. The connector is such that you cannot mess up the polarity. Can you open the appliance and find the battery, post a pic?

Placement of the battery in a m/b is simple, slide out the old, slide in the new. The plus sign is on top.

1 Like

131 CR2032 3.0V

and it looks liks this:

you can get those from eBay.

Ive reseated the RAM modules before (not during :wink: ) the memtest. Both memtest of the ram bars ran through 100% (45+ min) and prompted with no errors. So it seems the RAM is not the problem

OK i tried to install lubuntu. Full success! It boots and works, like an Intel Atom System should be!
Try to install IPFire again. Again at the entropy step it failed and reboot again.

The only Alternative i have right now, long term speaking, is switching to cheap travel router with OpenWRT pre-installed. :frowning:

Ok. Then maybee the ssd has problems. In this wait for entropy loop the system does nothing except write to a file to geneate some disc io interrupts.

OK here the complete try step by step what i tried today:

  1. Loaded “ipfire-2.27.x86_64-full-core162.iso” via Balena Etcher onto a USB drive
  2. Corrected date, acpi, ahci and usb-speed (high-speed) in bios. [Cause still no new Battery] Rest was untoched
  3. Used first option in IPFire Install Boot Menu
    [Now i can even get past setup proccess]
    First Try
    Got to choose the filesystem left the place came back and the setup was cancelled an the pc rebooted hisself
    Second Try
    Got to localisation option and then the pc suddenly rebooted

Switched back to the original SSD where OPNSense is still installed for testing right now.
Like in my previous post in this thread

No Problems, booted and working flawlessly!!!
Why only IPFire makes so much trouble to work properly???

You answered your own question! That little battery is very important.

1 Like

Nope! In my Eco the battery is also dead. Except from loosing time and some settings the box works
without problems. There must be an other fault. (The only difference in my prototype unit to the production version is that i have an older WLAN card.)