Multiple qemu quest on orange interface

Hi all,

I successfully created an orange network interface and qemu virtual machine, but I need a second one. Unfortunately when I try to start second qemu guest, I get an error message that the orange0 if is already busy.

I start the VM guest with the
-netdev tap,id=net0,ifname=orange0,script=no,downscript=no
-device virtio-net-pci,netdev=net0
parameter combination.

I’ve tried to create a virtual bridge and 2 virtual tap adatpers using “brctl” and “ip link” commands as I found it online but none of the guests saw the internet. Maybe it’s a routing problem, but unfortunately I really don’t know. (For example I’ve tried this: Documentation/Networking - QEMU)

Please, someone write a couple of commands I can use to share the orange0 interface between multiple VMs. (Or create a second orange interface, I don’t need the VMs to communicate with each other).

Thank you in advance.

Best Regards,

Have you gone to:

and set orange to “bridge”. With that setting, your orange0 should be shareable by VM.

1 Like

First of all, thank you for your anwser, but please be more specific, because unfortunately I’m quite noob on networking.
I’ve set the orange to bridge mode (then rebooted) but nothing changed. If I try to start second VM with ifname=orange0 still got resource busy. Maybe I should create virtual NICs somehow and assign them to orange, but I dunno how. I’ve also tried to create a secondary orange (orange1) similarly than this - QEMU but in /var/ipfire/ethernet/settings no use to add ORANGE1_MODE, etc. the orange1 tap created but no address assigned. Maybe I should edit /etc/init.d/networking/any script to work, but I’m afraid, that future updates will clash with such change.

I’ve looked into /etc/init.d/networking/any and after running these commands I’ve finally managed to create a working orange1 (of course it is not accessable or managable from IpFire web ui, but works:

modprobe tun
openvpn --mktun --dev tap1
ip link set tap1 name orange1
ip link set orange1 up
ip addr add dev orange1

After these I can run a second VM on orange1 but no communication works outside of ipfire internal network addresses. I assume that it is because of firewall rules, but I don’t know how to set it up by command line and especially make the rules permanent. It would be far better if I would be able to configure it on web ui as I can do it with orange0.

So this seems to be a dead end.
How could I connect the secondary VM to orange0?

I’ve had very limited success managing VM from CLI. describes how to set up login for the GUI virt-manager. I find that works well - if you get that working then you could translate the parameters to CLI, if the latter is your preferred way of working.

Each VM will need a virtual NIC, that virt-manager should default to orange0, in your case, because that is the only one defined.

None of this is manageable from IPFire WUI, but the basics are readily managable from virt-manager GUI on an attached workstation. I’ve put VM
only on green0 and YMMV with orange0