Monitor ipfire with icinga

Everyone,

I have a seperate vmware VM that I set up with Centos 7, running icinga2. I’m configuring the system to monitor all servers and devices on the network. I want to monitor IPFire as well. The documentation that I am working off of is using the base installation as an rpm file, but rpm is not installed / available with IPFire. I see there is an icinga pakfire add-on, I tried installing that, but that add-on seems to want to use ipfire as the master icinga server, I want to do the reverse, monitor ipfire from another machine. I also found the nrpe add-on wiki.ipfire.org - NRPE and that seems like it is what I need.

I’m at the point now where I want to configure IPFire with the node wizard. On Centos7 the command to run (as the client) is sudo icinga2 node wizard, but that command is not found on IPFire. Running icinga node wizard produces:

[root@ipfire nagios]# icinga node wizard

Icinga 1.11.4
Copyright (c) 2009-2014 Icinga Development Team (http://www.icinga.org)
Copyright (c) 2009-2013 Nagios Core Development Team and Community Contributors
Copyright (c) 1999-2009 Ethan Galstad
Last Modified: 05-28-2014
License: GPL

Error: Cannot open main configuration file '/etc/nagios/node' for reading!
Failed to read main config file.  Aborting.
[root@ipfire nagios]#

I’m not finding any posts in the icinga community page for ipfire, has anyone set this up before, and if so can you provide any documentation?

Hi @cwensink,

I have never used icinga but from your error message it looked like icinga was trying to find a configuration file called node under /etc/nagios

From the rootfiles list for the icinga add-on the config file under /etc/nagios is named nrpe.cfg
Not sure if that helps at all but it’s all I could think of.

I presume it is something like that. On Centos7 running sudo icinga2 node wizard brings up a series of questions that you answer interactively like this:

Please specify the common name (CN) [hostname] (press Enter)
etc.

I’m looking for the structure to get that wizard to come up. I ran a search for ‘node’ and nothing comes up in either system, so it does not seem to be a reference to a file, but rather a command argument configuring a ‘node’. I’m digging through the documents now.

I found this:

A tutorial on getting icinga up and going (instead of icinga2) and it looks like it’s pointing to /etc/nagios/nrpe.cfg which does exist on IPFire.

Still searching …