Lshw addon seems not to work

I installed the addon “lshw.”
I tried running several terminal commands:

sudo lshw
lshw -short

But I get the error you see in the image.
Has anyone had the same problem?
WHERE could I have gone wrong?
I know that command. On Xubuntu it works fine for me.
I thank you in advance.

002 - errore

I just installed lshw on my CU183 system and ran lshw -short

This is just part of what it outputted and it looks to be working for me.

H/W path Device Class Description
system apu4 (4 GB)
/0 bus apu4
/0/0 memory 1MiB BIOS
/0/4 processor AMD GX-412TC SOC
/0/4/7 memory 2MiB L2 cache
/0/9 memory 4GiB System Memory

I would try uninstalling it and then re-installing again to see if that helps.

1 Like

Same problem. I did the uninstall/reinstall from web/gui. Maybe it is better to install from terminal?

Does the addon have any package dependencies?

The same commands end up being run in both cases otherwise pakfire would be doing different things on the console vs in the WUI.

In terms of your problem, all I can think of is top search for the error message you get and see if anything comes up.


Okay. I’ll try to investigate. Surely the problem lies only in my machine. If I find out anything I will update the post :wink:.

I tried to google the error. There is a lot of talk about it, in many circumstances. I could not find much about my specific case. I tried ChatGPT. Below is the answer.

In any case, it is not super important for me to get this command working. You can queue this request.

his error, “terminate called after throwing an instance of ‘std::length_error’ what(): basic_string::_M_create”, indicates that a program has been terminated due to an unhandled ‘length_error’ exception in C++. This type of error occurs when attempting to create a string with a length exceeding what is allowed by the system.

In the specific context of the “lshw -short” command, it seems there’s an issue with string handling within the program, leading to the generation of a string with an unmanageable length, resulting in the error and termination of the program itself.

To resolve this issue, you could:

Ensure you have the latest version of the “lshw” program installed.
Make sure all system requirements are met.
Check for bug reports or similar issues in the “lshw” project’s bug tracker and, if necessary, report them to the developers.
If the error persists, you might look for alternatives or use other options to obtain the system information you need.

IPFire already has the latest version - B.02.20 - which was updated in IPFire in Jan 2024.

The only thing I can think of is that the issue you are seeing would need to be raised on the lshw git site so they can have a look to understand why it is occurring and how to fix it.


Yes. But then if it works for you, I really don’t think the problem is among those listed by ChatGPT :+1:.

Found the problem, perhaps. It seems that my machine is trying to install the old version. Here is the photo…


Update your lists on the pakfire page.

1 Like

Done and done again. Nothing.

Do you get an error message when updating the lists?

1 Like

No. From web/gui nothing. From terminal I never tried.

Last system update done 26d 23h 6m 52s ago.
Last server list update 7s ago.
Last system list update 5s ago.
Last package list update 7s ago.

lshw = .19

Package list update looks fine at being done 7 secs ago. Just don’t understand why the lshw version is the previous one. Certainlt different to whatbi had in my system.

Unfortunately don’t have time to investigate further at the moment. Will try and have a look tomorrow.

1 Like

I thank you from the bottom of my heart. In the meantime, I also investigate :smile:.
Have a nice evening.

1 Like

Even in the mirror I only see the old version:

lshw-B.02.19.2-1.ipfire	2024-02-10 12:43 	253K

Hash: SHA512

Name: lshw
Summary: HardWare LiSter
ProgVersion: B.02.19.2
Release: 1
Size: 276480
File: lshw-B.02.19.2-1.ipfire


There might be a pakfire cache that needs to be cleaned out. I dont remember where it is at the moment. In the IPFire terminal / console search for *lshw* and you should find it.

EDIT: I think I found pakfire cache. Do a pakfire Uninstall for lshw. Then look in the directory: /var/cache/pakfire and delete the lswh-????-?.ipfire file(s).

1 Like

I have just realised that lshw-B.02.19.2-1 is the version also showing in my CU183.

Looking through the git repo the lshw-B.02.20-2 version is in CU184 which is currently in testing.


Yes. that’s one of the first tests I did. But I still have the problem. At this point I am more and more convinced that the problem is isolated in my machine, although I don’t understand how it could happen to me. I will keep you updated if I solve it. Thank you as always for the very quick responses :+1:.

Are you using the test version by any chance?

I apologize. I reread it back. We use the same version.

I will wait for the next official version. I will update everything and let you know if it is resolved. I can’t think of any other solutions.