Local dns entry strangeness

I have proxmox running in my network, I created a ubuntu 19.10 server with the name plexbox. Looking at the ipfire dhcp lease it shows the ip address and the name correctly, however other machines on the network can not resolve the name.

On the ipfire box when I grep the dhcp-leases.conf file I see the ip address, but the name for that ip address is wrong, it says local-data: “ubuntu-server.exampledomainname.com 60 IN A” and of course the next line is:
"local-data: “ 60 IN PTR ubuntu-server.exampledomainname.com

so maybe this isn’t the right place to look… but how can the UI in ipfire get the right name and the unbound file not?

Also I will note that when I ping the name ubuntu-server it responds and it is the correct ip address.

Where did I screw up?
Please and thank you!

I gather that it is common practice to give servers (and network printers) fixed addresses (as opposed to fixed-leases or dhcp-leases). Those then get registered in Web UI > Network > Hosts.

In your case, it appears that the server is using the name in its own network configuration. You need to amend that to have it abide by the DHCP-provided parameters. It might also help to force the domain name in ubuntu’s setting. Other other machines need to resolve a FQDN, which might be plexbox.localdomain, if you have not changed IPFire domain name.

I didn’t explain things properly. The ubuntu vm runs correctly and is using DHCP, when you log on to it and run the hostname command it comes back with ‘plexbox’ which is correct. So let’s forget about this machine right now…

On another machine on the network when I do a ‘ping plexbox’ the address isn’t found. Yet as I mentioned in my original post the entry for ‘plexbox’ is listed in the ipfire dhcp gui. Also as I mentioned in the first post that when I remote on to the ipfire box and do a cat on the /etc/unbound/dhcp-leases.conf file the ip address is listed but to the wrong name.

Maybe when the installer was running it got a dhcp address as ubuntu-server but then after the hostname was changed by the acutal install the ipfire didn’t update the hostname… Maybe it’s a problem with the ubuntu 19.10 server installer?

Matt, I have the same issue when I create VMs on proxmox. Ipfire says there are registered with name and ip but I cannot ping by name. My solution is to stop/start dhcp and restart unbound.

1 Like

i tried restarting unbound but it was the same results. I also from the client tried doing a dhcp renew to no avail… However after the dhcp timeout period everything is working properly… but it’s a problem when i am creating new vm’s then trying to run ansible on them…

I agree, it is a problem but I think ipfire does not implement dns update for local network.
I stop/start dhcp and restart unbound on the ipfire console.
then I can ping the newly created VM and run ansible.

1 Like