LCDProc replacement for LCD4Linux

Hello, like seen the core kicks my LCD4Linux out…and so i tried to get the LCDProc running for my BWCT USB-LCD, which works fine within the LCD4LINUX configuration.
By the first shot, i got this back:

LCDd -r3
LCDd version 0.5.7 starting
Using Configuration File: /etc/lcdproc/LCDd.conf
Listening for queries on
hd_init_bwct_usb: interface may be claimed by kernel driver, attempting to detach it
hd_init_bwct_usb: unable to re-claim interface: Numerical result out of range
Driver [hd44780] init failed, return code -1
Could not load driver hd44780
There is no output driver
Critical error while initializing, abort.
By searching the net i found that there are some issues with this configuration with/for LCDproc, which are years back…but maybe present??? By the way, why the LCD4Linux was kicked out with this core?
I like to get back my information-board :frowning:
From my system, the device:
Bus 001 Device 003: ID 03da:0002 Bernd Walter Computer Technology HD44780 LCD interface
and my configuration (part)


actually i didnt really start with creating a layout for it…but i expect the driver should be loaded successfully first.

Anyone with in idea what to do…and where?

Your post was almost incomprehensible to me. I think you want to use some hardware that displays kernel information on a liquid crystal display and you get errors due to the specific driver being absent. The likely explanation is that this driver is not present in the kernel. If this is the case, the only option open to you is to patch the kernel yourself, recompile it and install it (and repeat the operation to any future version).

Keep in mind that any driver compiled in the kernel is a potential attack surface and therefore should be carefully evaluated by a cost/benefit analysis, especially for a firewall software distribution.

Before you ask the developers to do this for you, please read first this discussion thread: RoadMap for kernel update? - #11 by ms

Hi @heus

Various addons have been removed from IPFire as mentioned in the Core Update 158 announcement

due to no longer being supported or even the upstream project being discontinued.

The last release of LCD4Linux was in 2005 and the last development was in 2007. The source tarballs no longer exist. Trying to download any of the tarballs gets a 404 Not Found message.

Also see this post

Regarding your issues with LCDProc, I am sure there will be community members who will be able to help you solve your migration problems.

1 Like

Thanks @cfusco, but i fear you get me wrong.
In the past was a problem, can be find:
( LCDproc / Bugs / #44 Problems with BWCT usb devices (lcdproc-0.5.6) (
and from my point of view if this USB checks fails, by any reason…
the solution can’t be that i need to recompile it;
With the next core update i have to do then…what?
So I like to point into this direction, the “developers” or “builder” can’t test each individual configuration…
and so i try just to ask if there is one configuartion with this…
because i wasn’t sure if my configuration file was ok or not…
or if i can’t get it run because of the internl problem…
what i don’t like to overrule with any own re-compile actions…
the lib was in the past there, worked fine and i didn’t change any hardware…
so just to find where to search for.

1 Like

@bonnietwin: thank you for the explanation, make sense for me now!