Lack of full bandwidth on 2.5Gb internet


My system profile is here, - Profile 6d05fb28ac611340ba7e63bf08392abfde0109f6

I’m having a weird issue. I configured a basic setup of red and green zone, the NICs are Intel I225-V. I am new to ipfire and this issue existed in other solutions but not as bad. I have a 2.5Gb internet connection, which test at about 2.3Gb U/D from my main PC. I’m not getting full bandwidth though when using my firewall. I have no IPS, QoS or extra firewall rules in place.

What happens is if I run an iperf test from my main PC to an internet iperf I get 1.9Gb down, 1.1Gb up. Same with any speed test, about the same results. If start an iperf server on the ipfire firewall and test my PC to that, I saturate the connection fully up and down. If I run an iperf from the ipfire firewall to the same iperf server I check from my main PC, I get the full 2.3 up and down I expect. If I directly connect the PC to my ONT I get the 2.3 up and down as well.

I have no idea what I causing this to change when both sides test fine from the PC to the firewall and from the firewall to the internet. Note, I have no Intel and Realtek NICs in the PC and I get the same results from both. I run Manjaro Linux with 6.1 kernel on my PC.

You should test if the CPU introduces a bottleneck when your traffic needs to change network card.

For 2.5GBit up and down simultan your IPFire must be able to handle 10Gbit PCIe bandwich. Often this is also a bottleneck at cheap SoC’s.


That would at least make sense. The system I bought was supposedly supposed to be able to handle it. Won’t trust that YT channel again. Though doesn’t matter much as I’ll have to replace it anyway as 5Gb was just released in my area.

3 posts were split to a new topic: Can barely reach 2 Gbps in download