Known issues on restoring fixed DHCP releases?

I ended up having to create a new installation (core 165) yesterday using a fresh flashed SD for my Raspberry Pi and a backup downloaded from core 164 installation. It appears that things like OpenVPN setup were restored (thankfully), but not the fixed DHCP leases I had configured. Is that expected behavior? Is it a known issue?

This isn’t a big issue, I just thought I’d raise it here.

Yes, this is a known problem and is being worked on.

An updated patch is being built on CU166 in testing at the moment and after testing has confirmed it is working as expected the plan is to issue an emergency core update for this as soon as possible.


I have an older backup potentially from 163. How can I validate the version it came from and can that be restored on top of 165?

The problem occurred in CU164 so if you have a backup from CU163 then that will have all the directories backed up and you can use that on top of 165.

To confirm that it is from CU163 or earlier the simplest way is to check the directories that have been backed up in it. Basically the .ipf backup file is a tar archive so you can look inside it with a GUI archiver or you can extract the archive on the command line.

If you have directories like ddns and dhcp under the var/ipfire/ directory then you have the full directories.

In the IPFire bug there are two images one for the var/ipfire directory under CU163 and the other for CU164 so you can see the difference you would expect to see.

That worked perfectly. Thanks so much!