Issue with Red0

I have completed a fresh install of your latest release. After completing the setup I found that I could not access the internet. After spending over 8 hours of running tests I have concluded that the issue is in red0. I can connect with green anywhere on the lan. But there is no internet access. It does receive an IP address during boot from my internet provider. It’s all there. The strange thing I found was that I could ping the address assigned to red0 with no problems. But when I tried to ping the gateway or the dns addresses I got no replies. All of this was done from the IPFire pc. As many installs as I have done I have never ran into anything like this.
I will assume that I have in some way caused this issue. But I would really appreciate someone pointing out what it was that I did or did not do that caused this. And, is there anything I can do to fix it…

What kind of internet access do you have? CableInternet, DSL, … ?
If you get an IP through DHCP, red0 should be allowed to access the internet.

Just another thought. If you use CableInternet, which IP do you get, is your access device a real modem or a router in bridge mode?

  1. Cable Internet
  2. As stated previously, it connects and receives an IP address from my internet provider.
  3. The IP I get is different each time I reconnect to them.
  4. I have a real modem.
  5. I have been running IPFire for some time now and have been successful at fresh installs at least 5 times for myself and at least 3 for my brother. Never had an issue like this before.

Hello @maintech,

I live in the US and have a well known ISP. And I have an Arris SB6183 cable modem.

The ISP (or maybe the cable modem) keeps track of the MAC address of the device plugged into it. In my case it is the IPFire box.

Many times when I cannot get access to the Internet it turns out to be the cable modem. And “something” has lost track of the MAC address. Maybe the cable modem went bonkers!

The only way I’ve found to fix it is to turn off the IPFire and unplug (power down) the cable modem.

Order is important. First plug-in the cable modem and wait about 1 minute. Basically you’re waiting for all of the LEDs to light up.

Now power up the IPFire.

(rebooting / resetting won’t fix this)


You may have a point. I have changed computers that I run IPFire on. It would naturally have a different MAC address. I have turned off the modem lately but maybe I didn’t do things in the correct order. I will give your suggestion a try and thank you for your reply.

1 Like

No. It didn’t work. But it was worth a try.
I can ping on green0 and can ping my provider assigned IP address but can NOT ping the assigned gateway or anything on the web, I do show the correct gateway. My nameserver is which is the loopback. On most linux that would be wrong but with IPFire? It might be correct. I have internet by hooking my modem to my router but when I hook it to IPFire I get nothing. I reinstalled using an older version (2.25-core 158) and have the same problem. I can install Linux of any flavour and be able to have internet on either Ethernet adapter. I will most likely install Mint Linux on it again tomorrow to check if anything has changed. If not, I am at a loss of what to do next.

On the WUI System - Home menu page do you see IP addresses against the INTERNET and Gateway lines?

Does this page show that you are Connected with time connected in brackets or is it showing Connecting…?

1 Like

You can check the status of your internet connection on the modem also. should show you the status page of your Arris modem. There you can also find the ‘Event Log’.

Are you connecting your Linux systems directly to the modem or using your router?
There are two different approaches by the ISPs to bind the end point to an contract:

  1. the first MAC showing up at the NIC after boot represents the end point
  2. the MAC of the end point is registered at the ISP

Case 1 requires a modem reboot after end device change.
Case 2 requires a registration change at the ISP.

Which case represents your DOCSIS internet access?

Another topic is the IP you get from DHCP.
Just after reboot the modem serves its own DHCP. The Cable Modem answers to each request of a Customer Premises Equipment ( the end device ) with an IP out of, the lease time is very short.
After connection establishment to the Cable Modem Terminination System ( at the ISP site ) DHCP requests are sent through to the ISP network. The ISP’s DHCP server answers with a public IP.
Therefore we asked for the IP or entries on the status page.


It is now working. I will describe what I did though it makes no sense to me why it worked.
I booted a linux mint flash drive and checked both Ethernet cards. They were ok. I then used gparted to reformat the drive and to set it to GPT. I took another flash drive and copied the latest IPFire to it. I already had the latest on it but I thought a new download plus a new copy to the flash drive wouldn’t hurt a thing. I then installed it to the reformatted disk. When I booted it up, everything was just working. I guess it must have been a defective copy originally. I appreciate very much how so many tried to assist me. Thanks again guys…