Is ExtraHD broken in Core-Update 181?

A few core updates ago I was able to mount a USB stick using ExtraHD and share it via SAMBA.
Under Core-Update 181 when I insert the drive and attempt to mount it as “/mnt/USBPens” all I get is a RED dot but I cannot remove it by clicking the dustbin icon.
Restarting IPFire gets rid of it but thats very inconvenient.
And advice appreciated,

It is not a problem of ExtraHD not working with CU181.

I just inserted an 8GB USB stick into my CU181 and used the directory path you specified and got a mounted USB drive

I am also able to access the location and confirm that the text file I placed there is present via the IPFire console.

Can you show a screenshot of the ExtraHD on your system plus the contents of the directory

and the contents of the file /var/ipfire/extrahd/devices

also the result of lsblk from the console.

1 Like

Hmmm, I’ll try to do that tomorrow.

I put a second drive into the hub and that worked and I was able to delete it and then remount it OK

But when I clicked the red ones “dustbin” the green one went red !!!
so now I have two red ones and I cannot delete either!

There is definitely something odd when trying to delete a red entry. Restarting the machine with the discs
out and then re-inserting them then they reappear as RED entries and I still cant delete them.


I don’t use this feature.
But One Question if I may
Does the UUID of the USB change after reboot?
or when re mounting drive?

Looking in the code for the extrahd page the red button colour means that the code was unable to mount the device on the mountpoint specified.

What filesystem do you have on the usb stick that you are using?

1 Like

One is FAT the other FAT32

Then that is not the problem.

ntfs can’t be auto mounted because that filesystem type can’t be auto recognised.

FAT and FAT32 are no problem. Also EXFAT, ext4, ext2 etc are all auto recognised and can be mounted.

Removes that potential issue.

Did the code actually create the mountpoint. Does /mnt/USBPens/ actually exist?

1 Like

Can’t mount the drive at all. “Device” file is empty.

I have moved this to a new thread because the old one was related to not being able to remove a mounted drive whereas your problem is not being able to mount it.

There was also someone else having a similar problem to you.

I see that you have added comments into the previous bug report.

I am not sure if it is still part of that bug or a new bug situation.

The complete re-write of ExtraHD, after the initial hiccups has worked perfectly for me.
I just tried it again on my system and I was able to mount, access and remove the usb drive with no issues. This was an 8GB usb stick with an exfat filesystem on a single partition.

I have tried but I have been unable to reproduce the problem you are seeing.

I think it would be good to understand more details in the bug report about what filesystem is on the drive you are trying to mount, what directory you are trying to mount to, if that directory is created or not.

We need to understand what is causing the mounting to not occur for yourself but to go fine for me.

I have just seen that you have entered some info in the bug report about the filesystem etc.

I will try later on to try and follow the commands you used to see what happens to me.

This is a new “setup” (VM).

No mount point: lsblk

sda 8:0 0 32G 0 disk
├─sda1 8:1 0 512M 0 part /boot
├─sda2 8:2 0 32M 0 part /boot/efi
├─sda3 8:3 0 982.7M 0 part [SWAP]
└─sda4 8:4 0 30.5G 0 part /
sdb 8:16 0 500G 0 disk
└─sdb1 8:17 0 500G 0 part
sr0 11:0 1 451M 0 rom

But as always: I restore a backup to get my default config.

Manual mount works fine.

Interesting change of the GUI

Created another drive with the same result.


For testing and reconstruction of the problem I installed a new virtual machine with IPFire.

So this is the look after installation:

After that I forgot to create a partition and formatted sdb as ext4. However that worked (don’t know why).

After that the Add Pencil appeared. I defined “harddisk” as mount point, which failed. However here is the bug. Even the mount point is invalid, it adds it to the “device” file. Also I’m not able to delete it via ExtraHD GUI (Delete Bin has no effect).

I did a reboot. Here comes the first difference to the other, original VM: I can’t see an error message because of failed mounting during boot. I still can’t delete the entry via GUI. I deleted that entry manually in the “device” file. And now here is a other difference to the other, original VM: The GUI is ready to mount the device again. But I just checked the “device” file at the original VM again and… surprise… I could find a line break. That causes a second bug: blocks the functionality of the ExtraHD GUI.

Edit 23.01.2024

More bugs. There are so many bugs, it’s buggy.

Whenever I remove a harddrive I get an error on boot that the device couldn’t be mounted. However if I want to use the mountpoint to mount a new drive at the same place, I get this error: