Iphone cannot connect to Blue Wifi - Wrong Password

I setup my blue access point - installed and updated the WlanAP pakfire package. I added mac filtering for my laptop and telephone, both using a static set IP that matches the Blue Access - these addresses are not in the DHCP scope. For my laptop, there was no issue at all. It has access to Blue and Inet.

My Iphone cannot connect, it displays: wrong password for ‘SSID’. I noted the PWD in a notepad, copy & pasted and tried numerous times to conserve reality in my brain. I took in consideration that the Iphone has a option ‘keep mac secret’ which changes the MAC address it sends, I obviously have this on OFF.

Is this familiar? or with phones in general? I have no other one to test.


I do not use wifi on ipfire.
I Use wired AP. Less trouble
I have had problems with passwords for AP’s though.
Cut and past bad.
Non aphasia numeric characters, bad!
Some are case sensitive!
Good luck

1 Like

Here are no problems with connecting mobile devices like iPhone, iPad etc. with iPFire.

You already know that the MAC address can be changed through the settings in apple mobile devices/wlan/private WLAN address. This is set to “off” for you, so the MAC address displayed there is to be used in ipfire. That would have been my first thought too.

Hope s.o. can be of more help.


As I understood the point is to change provider to an wireless access hospot wan. wondering if that shoud be set up on the blue or red? it’s an access point. THough still need to install the add on to try and test but this would be my first tought. Wan on red. Other wise would be like asking my LAN to provide internet trought the hotspot, firewall IPS etc would have to be setup to inspect wan from that.
I think I reed right wan from the cellphone or sim card.
PS sorry I’m reading bad! WLAN wirless lan, THe ip ranges cannot interfere with green’s ip ranges, I supose.

Have you tried the steps below?

1 Like

Have you read the following Wiki pages?


1 Like

Sorry, but i can not second this

I’m using IPFire WLAN Accesspoint since i using IPFire - not a single Problem!

Hi iptom, I will definitely try the solution from Apple! Thanks for pointing this out. My phone has no issues directly on the router though. It’s a phone from work, so it could also be due to some settings I cannot control. Other phones have no issues on the blue, also the laptop can connect.

I will reset my installation with a Pi 4 due to ethernet loss on USB adapter / onboard card. Once I have it all setup, I will respond back here.

Device country language at WLAN 5GHz can cause such behavior. Check that either if you just use 2.4GHz.
Check additionally umlaut and special characters … The password digits length.


1 Like

I bought the Raspi 4 for the giganet connection (even on USB 2.0 it reaches 420/480 max) - first encountered some boot SD issues (-22) , fixed that and tried reconfiguring WPLan. Initially experienced the same, but found these settings for the PI 4, most likely the country code fixed the issue:

Using the On-board WiFi as Acces Point with hostapd

There are many reports about a problem running the on-board WIFI in AP mode with a country code set other that US (United States), so please try the country code set to US first.

HT Caps: [MAX-AMSDU-3839][HT40+][SHORT-GI-20][SHORT-GI-40][DSSS_CCK-40]

1 Like

Thanks for that @firewallsz. I run onboard WiFi and that suggestion doubled the speed for connected clients.