IPFire's VM can access the internet and ping the host, but the host can't find the VM

I followed several tutorials and tried several combinations to make the host be able to connect to IPFire’s VirtualBox VM, but it was all useless. Every tutorial shows something very straight forward that couldn’t not work, but I’m stuck in the stage just before accessing the web interface.

I’ve set the green interface to my default NIC bridged and the red to my VPN’s NIC bridged. Inside the VM, everything works fine, only in the host’s part that nothing is working. If I ping google.com from IPFire, it receives the responses, and if I ping the host, the host receives the ping, but it doesn’t ping back to the VM. If I access trough the browser IPFire’s green IP:444, it just keeps waiting for a response and then says that couldn’t reach the server. If I connect to https://ipfire.localdomain:444, the browser instantly gives an error as if the host doesn’t even know where ipfire.localdomain points to.

The green IP is The red is set to DHCP mode. My default NIC is in 10.0.0.x (inside the /24 subnet of my router), my VPN’s NIC is in 10.211.1.x.

Could somebody help me?

Update: I changed the green interface to “internal network”, now when the VM pings the host (VPN NIC), the host pings back. If I ping the red IP from the host, the VM pings back. But if I ping the green IP, it still can’t find it (time exceeded).

if you could make a simple diagram with draw.io

Untitled Diagram

Nevermind, I switched to pfSense, it worked out of the box…

Nice, that you could realize your config with pfSense. Nevertheless it isn’t clear yet, what you system you built.
Maybe it would help to show your system more precisely or to cite even some of the tutorials you tried ( may show us the problem indirectly ).