Ipfire.pool.ntp.org is not resolvable

This morning my IPFire PCs worked ok.
Tonight they all fail to work correctly.
The error message during boot up says:
Error resolving 0.ipfire.pool.ntp.org name or service not known (-2)
Error resolving 1.ipfire.pool.ntp.org name or service not known (-2)

What’s wrong ?

DNS server not accessible at that level of boot/time/whatever?

What is the TCP/IP number for the URL, so that I can ping same ?

There are many IP address for NTP. Here is what I see:

[root@ipfire ~]# ntpdate -qv 0.ipfire.pool.ntp.org
 3 Dec 18:53:13 ntpdate[13883]: ntpdate 4.2.8p15@1.3728-o Tue Jul 14 14:39:42 UTC 2020 (1)
server, stratum 2, offset +0.001520, delay 0.08435
server, stratum 2, offset +0.001112, delay 0.06277
server, stratum 1, offset +0.001742, delay 0.08482
server, stratum 2, offset +0.000525, delay 0.06143
 3 Dec 18:53:14 ntpdate[13883]: adjust time server offset +0.001742 sec
1 Like

If I “ping ipfire.org” , that works ok.
If I “ping 0.ipfire.pool.ntp.org” , that works ok.
But when I reboot the IPFire PC, I get the same error message ???
How can I fix ?

Work around found.
Used WUI to re-enable ISP DNS.
This allowed the IPFire PC to boot ok w/o the error msg.

Replaced two Verisgn DNS with two other providers.
Disabled ISP DNS and reboot ok w/o the error msg.

The original two Verisign DNS worked /w ping but stopped working /w IPFire ?

Maybe the Verisign DNS does not support DNSSEC…

1 Like


just to shed some light onto this: FQDNs such as these resolve to multiple time servers of the NTP pool project, which is why you will get different IP addresses almost every time you resolve them.

*.ipfire.pool.ntp.org is a so-called vendor zone (see here for further information on this), the infrastructure behind it is not owned or administered by IPFire.

However, it should resolve on your machine, so asking your question here is appropriate. :wink:

Thanks, and best regards,
Peter Müller