IPFire on VirtualBox is super difficult

I’m not really sure what the problem is with IPFire and VirtualBox, but the terminal is super unstable! Whenever it loses focus (because I am reading something on the IPFire site, out of VirtualBox), it either logs out and I have to log in again and again and again or it crashes beyond recovery and I have to restart the VM just to recover the terminal.

Anyway, I can’t make IPFire work properly in VirtualBox. It is running, but I can’t SSH or find the Web admin page. I am submitting some of my configuration. Will someone please let me know if I’ve done something wrong?

red and green should be on different subnets. Your post shows green and red

Why are both networks Bridged Adapter with same name, wlp1s0 ??

See wiki.ipfire.org - Oracle Virtual Box


Red and green should be on different subnets, but that is a matter of security, right? Why can’t I SSH either or access the web admin gui?

wlp1s0 is the interface I use to connect to the ISP modem. When we use bridged connection in VirtualBox, we’re told to use the physical interface that connects to the Internet. By the way, I forgot to say that red does have Internet. I can ping external sites from the command line in IPFire. Note that the two virtual adapters have the “same name” but different MAC addresses.

No. This has nothing to do with security, you get a serious network routing problem which cause in not reachable services. If you have to IP’s in the same subnet all traffic to this network will send to one of the nic’s. If you try to connect the other IP the answer packet will go out to the wrong nic.

Also your MAC addresses looks illegal (or are you XEROX?). The first bit must “0” and the second bit of the first byte must be “1” on a self assign a address.
x2:xx.xx.xx.xx.xx x4:xx:xx:xx:xx:xx … are valid but this should not cause your problems.


BTW: I recommend to look at the new topic Tutorials and Learning Material for Newbies on the wiki start page.

1 Like

Please note this is VirtualBox. I can “spoof” MAC addresses at will. I chose those because they are a lot easier to identify. That doesn’t make them “illegal.” That exact same scheme works fine in OpnSense.

Now, I changed red to a 192.168.* network and green to 10.60.*, no blue. I still can’t ssh even from within IPFire itself. This is really confusing.

What is that problem with a public key that IPFire is complaining about?

Note: I changed the sshd port to 222 in /etc/ssh/sshd_config, to keep up with the old practice.

you cannot ssh to red (blocked), you can ssh to green.

1 Like

Neither is working.

The Web UI of ipfire has an option to enable ssh access to green (default is no). The page can be accessed from System > SSH Access. It looks like:

First, I enabled ssh access and then clicked on the last checkbox, ssh to 22 instead of 222.

The Web UI should be

That address does not respond at all.

I wonder if this glitch with dhcp is relevant.

This isn’t a ‘glitch’, this is an error!
From the console you should inspect /var/log/messages. There are the errors documented.

OK. I remember I chose no DHCP during installation. How do I bring up that DHCP configuration dialog again? It’s not part of the ‘setup’ utility.

You should try to access the WebGUI from a device in green, the IP must be set statically to a value from the green net ( not the IPFire address ).

My green IP is It is completely irresponsive.

I reinstalled IPFire just so I could reconfigure the DHCP server since there seems to be no way to do that from the command line after installation.

All the same IPs. No errors printed in the boot sequence now.

SSH still blocked with “permission denied.”

Web GUI still unaccessible.

This is really hard. Maybe IPFire just does not work on VirtualBox.

Ipfire works well on Virtualbox. I test every release there before updating prod env. Let me ask what is your host network (since red is picking up a 182.168 address) I assume that is your host network.

ISP ---- some router ------------ VM (wtd) picks up via DHCP. In setup you defined green as If you have another vm, assign it and ping it should work.

1 Like

IPFire works fine with Virtual Box.

I have a full network for testing and development purposes with IPFire with red, green, blue and orange interfaces and with two virtual clients in each of the green, blue and orange zones.

In an earlier post you had both red and green on a bridged network but with the same physical interface name wlp1s0 (wireless interface).
With the bridged interface you require a physical interface and the name should be the same as used on the host. Therefore the red and green interfaces should have two separate physical names. Your physical real client would then connect to the physical interface being bridged for your green network.

If you are looking at using a virtual client instead of a real client then your green interface should be set up with the Internal Network option instead of the Bridged Network option in Virtual Box. That is what I am using for green, blue and orange. I only have red on the bridged network.

1 Like

There was a wrong option in sshd_config. I fixed it and now I can SSH IPFire from within itself. But I still can’t SSH it from the host/desktop or access the Web GUI.

Your host by default cannot access a VM (see VB network types). What you might do is:

  1. change adapter 2 to host only adapter, ‘Virtualbox Host-Only Ethernet Adapter’)
  2. From the VB window, File > Host Network Manager and configure adapter manually instead of to (in effect you tell VB to create its own network that the host can see)
  3. from your host, should work
1 Like

If red is connected to a bridged network adapter on the host then you can access IPFire via red but you need a port forward rule, the same as for a physical ipfire setup.

1 Like