IPFire on Raspberry Pi 3 B+ slow download speed

This might be considered a noob question to some, but here it goes. Has anyone run across slower download speeds when using the Raspberry Pi 3 B+ as a router with IPFire?

My throttled rate from Comcast is 100 Mbps. On my laptop, which I’m using for IPFire currently, I get a solid 94 Mbps which is definitely acceptable. I’m wanting to switch to the pi to help reduce the electric bill.

My speed test shows 30 Mbps down from the LAN PC to the internet using the pi.

Here are the tests I’m using with iperf3 on my LAN PC to IPFire.

If I run a speed test from the LAN PC to a public iperf3 server, the story changes and it drops down to 5 Mbps.

For the red interface, it’s using the gigabit ethernet, and for green it’s using a USB 3.0 to ethernet adapter. Would the bottleneck have anything do with the fact that the gigabit ethernet is using a single USB channel?


I haven’t tried swapping the interfaces. Would it make any difference? If there is additional troubleshooting I need to be doing, I’m open to suggestions.

Here is the iperf3 result from the LAN PC to a public iperf3 server.

The problem might be unsolvable on RPi 3+.

USB 2 is a shared bus and if RPi 3+ is handling onboard Ethernet, SD card, Ethernet Dongle and perhaps WiFi, Bluetooth & keyboard all on a single USB 2 channel, then the bandwidth for each device is much reduced. I can’t offer a useful comparison. My Nano Pi R1 does not share so much on one USB bus, but my Internet is throttled to 12 Mb/s.

Your best option is probably a mini PC - if you are not already using one.

I had a feeling that was the issue. You basically confirmed my theory. Thanks!