i am trying to setup IPFire on a new motherboard (GA-Z68AP-D3). i am using a CD-ROM and up to the point of taking out the disc and rebooting seems normal. But then it comes up with “DISK BOOT FAILURE” when i try to continue using the HD. i tried a second SATA HD and the same result.
Any ideas on where i am going wrong?

Did you use The ISO or the Flash img?
You need the ISO x86 64

1 Like

i used the ISO x86_64.
But here is an update! i installed it using an IDE controller card for an older disc drive.
So i took out that IDE card and set it up again using an SATA disc drive. i ran the setup and configured the networks. But when i take out the disc drive or even disable it in the BIOS as a start up device i get
“GRUB loadingRead Error”
When i put the disc drive back in and set it as a first boot option IPFire boots. It sounds like i need to edit the GRUB, but i’ve never interfered with that before.

Try installing to USB stick
Possible Hard drive failure, sata Cable?

Make sure your install boot media and OS boot media are both using the same boot method. If CD boot is BIOS/CSM then the boot drive should also be BIOS/CSM mode. Same for EFI, both boot methods should match or it will fail to boot.

Second issue sounds like grub was installed on a different drive than the system. I suggest installing/enabling only the drive(s) that will be used and install again making sure boot methods all match and making sure grub is installed on the system root drive.


For the first issue i took out the IDE card and just used a SATA disc drive instead. Now that i think about it the older system was set up using and IDE HD and disc drive. That motherboard died on me so hence the new setup.

For the second, there was only 1 HD in the system so the boot information has to be on it - i’d guess. But i went down to the local computer shop and bought a cheap second hand SATA disc drive and put it in as the first boot device. IPFire now boots fine and i am currently using it. So this is sort of a solution?

The price of small SSD drives is so low they are my go to for Dedicated appliances like IPFire.

1 Like

I generally agree and SSD should not be a problem with the subject mainboard. A caution with older single-core and some dual-core mainboards is that those tend not to support AHCI, in which case SSD won’t trim.

Your new mainboard is somewhat power-hungry for a firewall device. However you deploy it, consider an mSATA SSD, which attaches directly to the mainboard, thus avoiding cables

1 Like