IPFire Build Environment: Missing configuration script

It’s about 10 years ago when I had an build environment of ipfire for the last time so I’m not common with its structure anymore.

If I remeber right there should be a configuration file in the root directory of the build environment with its sources and make script, but I cant find it. There was not problem with building ipfire from scratch so my build environment works fine.

Therefore I cant run ./configure. What am I missing?

Thy alot.


The IPFire buildsystem never had a configure script but you can create a .config textfile in the folder where make.sh is located. But there are only some usefull variables like.

TARGET_ARCH= (i586,x86_64,armv5tel,aarch64) default is system arch.
ENABLE_RAMDISK= (on, off, auto) default is auto (if more than 4GB free use ramdisk)
IPFIRE_USER= (username for upload of the IPFire server)

Most of this should work in default (if no .config is present) and the arch can also specified on commandline.

I propably mess up with something… I’m looking for this tui where you can check or uncheck parts/components/functions/programs to build.

My final plan is to update/replace a Sierra Wireless driver for my EM73xx wwan cards that is not functioning with ipfire but other linux os.

IPFire does not have that. You are thinking of buildroot and OpenWRT is using that for example.

The problem that you have is very unlikely driver-related. It might be that the device is not properly ejected when it is inserted and therefore does not change into modem mode. That would be a problem in usb_modeswitch. There could be some other timing issues, but generally you are talking to your device and that is what the driver does and it works.

Too bad and I thought ipfire has that as well as I thought to remember playing around with that when I tried to get an wifi card to work a long time ago.

But the problem exists with two different laptops: Lenovo T440s with EM7345 + Panasonic Toughbook CF-C2 with EM7305.

Both wwan cards work fine with the latest Ubuntu and Kali so it can’t be hardware related.

I am not saying that the hardware is broken. It is just not set up to be ready to act as a modem.

I can say that CONFIG_USB_SIERRA_NET and CONFIG_USB_SERIAL_SIERRAWIRELESS is enabled as module in the IPFire Kernel.

I fear that this card not support the pure modem mode and they use a AT command interface to unlock the SIM and set the APN’s but after this the connection is handled via an Ethernet device. This mode is not suported by the IPFire network init skripts.

to reach the kernel config you have to disable the ramdisk, run a full build and after this go into the build-shell (./make.sh shell) and go to /usr/src/linux and run make menuconfig

I don’t have that folder. I’ve only got in /usr/src: cache, ccache, config, doc, html, langs, lfs, log, src.

You have to disable the ramdisk in .config and run a build before.
If the ramdisk is enabled /usr/src/ is not permanent.

I did that but first built and afterwards disabled it (was already built in the past). Do I have to do it the other way around?

delete log/linux-4*
and run the build to kernel built. (the full kernel not the header part)
You can break if the kernel compile has really started (run tail -f log/_build-ipfire.log in a seperate shell to see)
then run
./make.sh shell
cd /usr/src/linux
make menuconfig

I’ll try that when the PC isn’t busy anymore. Thx.

Hm I’m not sure if I’ve deactivated it at the right place.

in make.sh:

CONFIG_ROOT=/var/ipfire # Configuration rootdir

if [ "${ENABLE_RAMDISK}" = "on" ]; then
	mkdir -p $BASEDIR/build/usr/src
	mount -t tmpfs tmpfs -o size=4G,nr_inodes=1M,mode=1777 $BASEDIR/build/usr/src

So I was looking for the ENABLE_RAMDISK parameter but couldn’t find any config file so I set in make.sh

# Default settings

But there is

# Load configuration file
if [ -f .config ]; then
	. .config

which may overwrite the parameter again. Can’t find .config. Where the hell is it? I now created a file “.config” in /build//var/ipfire and included the parameter ENABLE_RAMDISK=“off”.

Still no such directory.

Your location of .config is wrong it must be in the folder like make.sh

God damn it and you wrote in a previous post… :cold_face:.

OK I’ll try again. Thx.

There is still noch such directory.

my .config file was added manually and ended up here --> /home/pi/ipfire-2.x/.config

$ cd ipfire-2.x
$ pwd

$ ls -al
total 160
drwxr-xr-x 14 pi   pi    4096 Apr  1 15:59 .
drwxr-xr-x 28 pi   pi    4096 Mar 31 17:36 ..
drwxr-xr-x 21 root root  4096 Apr  1 15:59 build
drwxr-xr-x  3 pi   pi   32768 Mar 31 16:35 cache
drwxr-xr-x  3 root root  4096 Mar 31 16:36 ccache
-rw-r--r--  1 pi   pi      19 Apr  1 15:12 .config
drwxr-xr-x 94 pi   pi    4096 Mar 31 15:14 config
drwxr-xr-x  2 pi   pi    4096 Mar 31 15:14 doc
drwxr-xr-x  8 pi   pi    4096 Apr  1 15:59 .git
-rw-r--r--  1 pi   pi     153 Mar 31 15:14 .gitignore
drwxr-xr-x  4 pi   pi    4096 Mar 31 15:14 html
drwxr-xr-x 11 pi   pi    4096 Mar 31 15:14 langs
drwxr-xr-x  2 pi   pi   20480 Mar 31 15:14 lfs
drwxr-xr-x  2 root root  4096 Apr  1 17:14 log
-rw-r--r--  1 pi   pi    1647 Mar 31 15:14 .mailmap
-rwxr-xr-x  1 pi   pi   48357 Apr  1 11:50 make.sh
drwxr-xr-x 17 pi   pi    4096 Mar 31 15:14 src
drwxr-xr-x  3 pi   pi    4096 Mar 31 15:14 tools

$ cat .config

Do you get the folder @arne_f is talking about, if you disable the ramdisk?

the one with make.sh in it??


find / -iname make.sh

Do you find any make.sh files?