IpFire Boot fails on Raspberry Pi 3B

Dear community,

I used ipfire on virtual machines many times so I know it quite well. Now, to built a wifi router for home, I’m trying to install it on a Raspberry Pi Model 3B (not +). I followed this guide:

https://wiki.ipfire.org/hardware/arm/rpi/three

and downloaded the latest Arm image and burned it to a microSD using BalenaEtcher. The Raspberry show a coloured pattern on screen and nothing happens. As far as I know this should indicate that it was not able to load the kernel.
For your info: I loaded in the same sdcard another image and everything works fine.
Somebody can help me? Thanks

Regards,

Mario.

Hello Mario - welcome to the IPFire community!

I grabbed a Raspberry Pi Model 3B (without the +) and the current ARM image from https://www.ipfire.org/download/ipfire-2.25-core144. And then used BalenaEtcher Version 1.5.81 to burn the image onto an old 8 GB SD Card. And I have a HDMI cable plugged into an old small HDTV.

When I boot I see four IPFire icons across the top left of the screen.
ipfire_tux_512x512-4b@0.5x

Plus lots of Linux “stuff”. Then the screen clears and I see four IPFire icons across the top left of the screen…

… and then nothing!

So something isn’t right. Maybe try with and older build for now. And I’ll try the same.

EDIT: shhh! I found where they hide the old images: https://mirror1.ipfire.org/releases/ipfire-2.x/

Doh! I forgot about the serial console!

EDIT: So once I do things right with the Serial Console, now Core Update 144 starts up OK the beginning of the install.

Can you take a picture of the colored pattern you see?

Dear Jon,

sorry for the late reply, I wanted to do some other test before replying. I used the same version of ipfire and balena etcher as you but again without success. I also used another card reader. No way.
This is the picture I see.

I had the same thing a few years ago and I think it was related to a bad SD card. Have you tried a new SD?

I searched the internet for “raspberry pi boots with colorful square” and I saw things like:

  • bad SD card
  • bad image burn
  • bad power supply
  • bad kernel file
  • disable splash screen

The bad SD card is the most likely…

Dear Jon,

I burned another distro on the same sd card with the same card reader and BalenaEtcher (OpenWrt) and it works well. Also tried another card. I’ll retry again and again.

Hopefully you won’t need to try “and again”… :crazy_face:
(this shouldn’t be this hard!)

it might help to download a new image for IPFire ARM

I meant, some other test (different sd card, card reader, burning software, ipfire version, power supply and so on)

1 Like

From your previous tests, all of the above are working. A bad download of IPFire can happen, particularly if it is interrupted & resumed.

Can’t believe! I downloaded again the image, and used yet another sdcard (the 3rd one) and now boots! I don’t know if it was a corrupted image or defective card, but now works and this is nice!
Thanks guys for your prompt help :slight_smile:

Consider to specifically test your two previous SD Cards for defects.

Better still, omar_ita, write the newly downloaded image to one of the earlier SD cards. If that SD then boots correctly then it was, indeed, the earlier downloaded image that was faulty.

If you ask you the next time the same thing if a image corrupted or not its maybe the best thing that you should do after download --> check the hash

Hi, I had the same problem
its very simple
without any change
just use flash disk Instead memory

This thread is more than 2 years old. I don’t think the problem is still present.

1 Like

i solved today after one week
There is no solution to this problem
I wrote this for others to use