IPFire behind Cable-Modem

Hello,

i have a pretty simple network at home. Its a cable-modem (eu-docsis 3.1) and an APU running IP-Fire behind the modem. Then my computer and wlan is connected to the APU in green and blue.

i am just not sure how to configure the red interface? do i choose DHCP or PPP DIALUP?
image

Many thanks
Dubdia

Hi,

first, welcome to the IPFire community. :slight_smile:

Most likely, you will need to set “DHCP”, so IPFire dynamically obtains an IP address from your cable modem. Please refer to the documentation for further information.

Thanks, and best regards,
Peter Müller

1 Like

Thanks for the fast response :slight_smile:

I tried DHCP at first but had no access to the internet so i thought it might be a misconfiguration here. I guess it is a problem that needs to be resolved by my provider (Vodafone) then?

Hi,

hm, could you post a screenshot of the start page of your web interface (as displayed here)?

I would be surprised if your cable modem behaved differently to IPFire than to any other system requesting an IP address via DHCP. Could you try to ping something like 8.8.8.8 from a computer behind IPFire and post the output here?

I don’t think so - besides, residential ISPs are usually not that eager when it comes to customers using something different than the hardware they supply… :slight_smile:

Thanks, and best regards,
Peter Müller

2 Likes

Which device from Vodafone do you use?
Is it switched to bridge mode?
Do have internet access just at the LAN port of the ‘modem’?

I use the same configuration with a ConnectBox in BridgeMode without problems.

Hi,

i am using a Technicolor TC4400 as cable-modem without the modem-router from Vodafone.

I just made some screenshots of the modem:

And here is a screenshot of a new installation of IPFire where red0 is configured with the DHCP option:

The ping results in a timeout (also the ping from by windows pc results in timeout):

ping

I would be really greatful for any ideas or tips!

Many thanks

Dubdia

I’m not sure. But I think getting a 10.xx IP shows your modem isn’t provisioned yet. Usually you get a public IP from the CMTS.

maybe configure red as STATIC with that 10.175.. ip

As some stated already above, you will most certainly have to set your internet connection to bridged mode in Vodafone customer portal.

It looks like DHCP is still active in your cable modem giving you private IP addresses instead a public one.

I suppose the modem is in bridge mode. Usually the modem/routers give an IP out of 192.168.0.0/16 in a /24 net.
The 10.175.0.0/16 IP seems to be an IP of the CM(TS) network of the provider.

thanks for your replies!

@bbitsch the technicolor tc4400 is a pure cable-modem… i think there is no bridge-mode to configure? at least i have not found it in the web-interface.

@hellfire i turned the bridge-mode on in the vodafone customer portal and re-started everything. I saw that the modem was waiting for a dhcp offer that did not came. After some time it got the 10.175 ip again.

Yes, maybe its not privisioned, i call Vodafone now and keep you up to date :slight_smile:

2 Likes

I had to connect my computer directly to the cable-modem (without the ipfire in between) and navigate to https://kabelmodemaktivieren.vodafone.de in the browser. Then i was able to activate the modem with my customer number and activation key. After that, ipfire had access to the internet :slight_smile:

3 Likes