Ipfire and freebox => TV through vlc / multipost

In france we have a freebox which allow to see the TV. I redirect all the traffic to ipfire like a bridge mode
On my lan I connect to IPfire which redirect my traffc through the freebox to internet
Since core 2.26 I was able to see television through vlc as it is suppose to do (rtsp protocol ?)
something has change in 2.27, because for example “mafreebox.freebox.fr/freeboxtv/playlist.m3u” request return a “null” and I am not able to see anything
any suggestion please ?
thanks in advance

I can understand freebox is purely french so it is quite difficult to explain
second everything else is working fine like before(internet,…)

Hello @mrelfire,

on some of my windows machines it still works with IPFire core update 160.
On others, it hasn’t worked for some time and I haven’t had the time to investigate.

Bonjour @mrelfire,

sur certaines de mes machines Windows, ça fonctionne toujours avec IPFire core update 160.
Sur d’autres effectivement, ça ne fonctionne plus depuis quelques temps et je n’ai pas eu le temps d’investiguer.

My config:
Windows workstations : Green network
Freebox : Red network
Authorized rule (IPFire) : (UDP ports 33000 to 65500) to Green (IP workstation)

Best regards, Steph

thanks, but I did not change anything except the upgrade
I do understand than perhaps it was wrong before

P.S. I try to reproduce your rule but it deson’t work (perhaps I do not undersqtand it clearly :wink:

PS: In IPFire, i also created a service (FreePlayer2) - UDP - ports 33000:65500 and accepted the opening of Windows Defender firewall :
Autoriser exception pare-feu

Thanks !
but unfortunately it doesn’t work …

I am totally lost
Firewall is ok (as before)
rediretion of port : not sure ( never done it before)

Just to be sure to have the same network config …

Freebox Server and Freebox TV are in the RED network (upstream from IPFire)

The PCs I’m running VLC on are in the GREEN network

I created a custom service (IPFire> Firewall> Firewall group> Services> FreePlayer2 / UDP / 33000: 65500)

I created a rule (IPFire> Firewall> Firewall Rules) with the following settings …
Source> Source address:
NAT> Use translation…> Destination NAT…
Destination> Destination IP address…: eg.
Protocol> Services: Eg. FreePlayer2

Activate the rule

Note 1: My PCs are declared in a private network (Windows)
Note 2: VLC TV channel consumption per PC of ~ 5.1 Mbits / s in HD / ~ 2.2 Mbits / s at low speed

== French translation (this only works on the Freebox ISP - in France) ==

Histoire d’être certain d’avoir la même config réseau…

  • Freebox Server et Freebox TV sont dans le réseau RED (en amont d’IPFire)

  • Les PC sur lesquels j’exécute VLC sont dans le réseau GREEN

  • J’ai créé un service personnalisé (IPFire > Pare-feu > Groupe de pare-feu > Services > FreePlayer2 / UDP / 33000:65500)

  • J’ai créé une règle (IPFire > Pare-feu > Règles de pare-feu) avec les paramètres suivants…
    Source > Adresse source :
    NAT > Utiliser la traduction… > Destination NAT…
    Destination > Adresse IP de destination… : par ex.
    Protocole > Services : Par ex. FreePlayer2

Activer la règle

Note 1 : Mes PC sont déclarés en réseau privé (Windows)
Note 2 : Conso chaine de TV VLC par PC : ~5,1 Mbits/s en HD et ~2,2 Mbits/s en bas débit

Could you post in English please?

1 Like

@bbitsch ,

yes, of course :slight_smile: !


Thank you! So it is comprehensive for all. ( at the language level, we agreed to :wink: )

Thanks but Unfortunately it doesn’t work

I am surprise you redirect port, it should be a kind of UpnP or something like that because you can run VLC on all your computers on your network

VLC communicates with the Freebox or its player (RED network) which returns the video stream to the PC on the other side of IPFire (GREEN network)

If I deactivate the rule in IPfire, the broadcasting of TV channels via VLC no longer works