IPFire 2.29 (x86_64) - core183: Issue w/cpufreq?

Not sure if this is a bug or something particular to my device. See clip from my system log below. I’ve tried removing and installing cpufrequtils, but it doesn’t correct the issue. My device is an HP T-620 Plus with an AMD GX-420CA APU SoC.

|14:22:09|kernel:|amd_pstate_ut: 4 amd_pstate_ut_check_freq^I fail!|
|14:22:09|kernel:|amd_pstate_ut: amd_pstate_ut_check_freq cpu0 max=65661217 >= nominal=65661280 > lowest_nonlinear=-30591 > min=-30591 > 0, the formula is incorrect!|
|14:22:09|kernel:|amd_pstate_ut: 3 amd_pstate_ut_check_perf^I fail!|
|14:22:09|kernel:|amd_pstate_ut: amd_pstate_ut_check_perf cppc_get_perf_caps ret=-19 error!|
|14:22:09|kernel:|amd_pstate_ut: 2 amd_pstate_ut_check_enabled^I success!|
|14:22:09|kernel:|amd_pstate_ut: 1 amd_pstate_ut_acpi_cpc_valid^I fail!|
|14:22:09|kernel:|amd_pstate_ut: amd_pstate_ut_acpi_cpc_valid the _CPC object is not present in SB IOS!|

The current version of cpufrequtils was last updated 9 years ago and is no longer maintained as the functionality has been built into the kernel.

Other people have had problems with it at the end of last year but usually when it was trying to use the amd_pstate driver with intel processors being used in the hardware.

Do the error messages go away if you uninstall cpufrequtils?

Thanks for the reply. When I remove cpufrequtils, the error messages go away; however, the APU comes close to locking all 4 cores to 2 GHz instead of regulating between 800 MHz and 2 GHz. System CPU usage shot up to a constant 98% as well without cpufrequtils.

see https://community.ipfire.org/t/ipfire-2-27-core-update-173-is-available-for-testing/9322/15

However, I find that on my AMD APU, whether the older A6-1450 or recent Athlon Silver 3050e, cpufrequtils needs to remain installed, for frequency scaling to be effective.

I don’t get error messages on either box. Those might be peculiar to your firmware or APU. Perhaps the messages can be ignored, since frequency scaling is effective, if there are no other problems.

Thanks for pointing out that thread. Without cpufrequtils installed, even following that procedure, my APU just doesn’t behave. With it installed, even with the errors things seem to operate normally. I’m leaving it as is for now and probably look for references to similar issues on other platforms with this APU.

Sounds like a bios/uefi problem. The updated amd pstate driver try to read the best config for the hardware from the bios which is missing.
I think cpufrequtils is not real the reason but it switch the gouvernor from performance to on-demand with cause the kernel error.
You need a bios update to get rid of this.


Makes perfect sense. Unfortunately, the last BIOS update is from July 2021, and that is the BIOS I am currently running. This is a great box for hosting IPFire, but it looks like I will have to just ignore the error or get something newer.

I have the same hardware.
Will let you know my results when I update.

1 Like

Latest bios available for this hardware seems 00.02.19 Rev.A
Have you both the same version?

That’s the BIOS I am on. I’ve loved this box – draws max 10-11W (usually much less at steady state) and has no trouble passing through my 1 Gbps internet with minimal bandwidth impact and IP running along with the FW.

Mine is fine, but not in the latest bios. Try to play with tmp settings.

I have a new installation of 182 from a few days ago and I upgraded it today. It looks like my CPU has been running flat out. To cure this I had to install cpufrequtils and reboot. This changed the governor from performance to on-demand. On-demand was not available to use before installing the cpufrequtils, but something similar could be achieved by changing the governor to schedutil without installing cpufrequtils.

Having said that, the CPU frequency graph is broken the minimum speed on the graph is way above what the CPU is idling at (800Mhz):

This is mine… So far looks the same.
Never pay much attention to it.

You’re basically running it at a much higher power than necessary. Max draw is only about 10W on the T620 Plus, so not a huge deal, but you should/could be drawing a lot less if power scaling was working properly.

According to https://en.wikipedia.org/wiki/List_of_AMD_processors_with_3D_graphics

the GX-420CA is a 25 W chip. You would need to be scaling back to close to its minumum of 800 MHz to get down to 11 W. That might not be possible for any IPFire running more that default processes.

1 Like

First party for data
However, as embedded CPU, I’m not expecting a full bore (energy speaking) at 100% of time.

See this article for their experience with this box. The highest power draw I’ve seen with it plugged into my KILL-A-WATT device is about 10W which agrees with their observations in the middle of the article. Much depends on the design outside of the TDP spec for the chip itself with respect to power draw.

This amd_pstate_ut problem is a bug in the cpufreq initscript. It try to load all cpufreq modules but amd_pstate_ut is a special module to test the parameters. And on all hardware that not support amd pstate it throw such errors.

Amd pstate was first added in zen2 architekture so it is normal that this error was reported but cpufreq will work normal. This bug is fixed since cpufrequtils-008-13 which is currently in testing.