IoT Advice (Washer/Dryer Wifi Connection)

I purchased a Maytag washer/dryer with a wifi connection. It has a companion mobile app. There is no network configuration on the machine(s), so I can’t manually manipulate the IP address or view the MAC address. The manufacturer used to label the machine(s) with the MAC address, but for “security reasons,” stopped doing that. After speaking with Maytag support, they confirmed that the only way to make the wifi connection is through the app that uses a bluetooth connection to initiate it.

The bluetooth route gets to the point of asking for and accepting the SSID, but the machine(s) are not pulling a dynamic address from the firewall. They are both within 10 feet of the access point, so signal strength isn’t the issue. I don’t see them in the current DHCP leases, and so I can’t give them Blue network access. If I had the MAC address, I could add it manually, but that’s not an option. I figured that I could set up a separate network using a generic router to view the MAC address then set it up manually, but was hoping to avoid that complication. Is there any way to disable the requirement for Blue network permission temporarily? Any other advice on how to proceed?

Seems that DHCP client of the device is lacking of some features for retrieve configuration.
This already happened before with IPFire (as client, not server) therefore… a long trick.

  1. Retrieve an old fashioned wireless router (nat capable), configure it without any Wireless security, as default LAN interface with DHCP server, and DHCP client on WAN, connected to the Blue segment. Try a run with a smartphone (not use that for sensitive data) then
  2. try to connect your IoT thing to that network, keeping (only for this run) the phone on the same wireless network, then force the IoT to update (if possible) the updated firmware.
  3. with the Washer connected, get the MacAddress from the DHCP Server of your router
  4. add the culprit macaddres to your favourite firewall list. BLUE IMVHO is an excellent start, maybe outside the segment used for special rules for access to green.
  5. try again the run on your default AP on Blue Network
  6. if something missing on the network capabilities of the product, bash with a large hammer the Customer Support for have access to the tech support and explain them what IoT should not be
  7. If a “decent” security setup is not possible: spread the word. Forums, Socials, Tech sites, tell your story about a brand that don’t want to make reliable and secure IoT devices.

A little “story” from July.
A customer installed several (9) AC/Heating units (with inverter) from Daikin. Network has been rearranged the last year, and the devices did not appear steadily on the available list on the app.
They connected, they dropped, then they show up again.
After a short survey, the PC was working great, the phones not so much. Raised the Wireless monitor software, then it banged: 12 years old 802.11g AP signal seemed like a basket ball when played on court, absolutely unstable and waving from decent intensity to quite no signal.
Long story short: AP on the floors involved has been replaced with newer one, 802.11ac capable. Issues disappeared, all the units get connected and updated.

The Daikin App (for iOS at this experience) also provided the immediate firmware upgrade of the Wireless Lan Dongle (files stored into the app)

That’s a more complete solution to what I was thinking. Your explanation is very helpful, Thanks! Will try this and report back.

I added an interesting experience on Daikin AC units. Take a read.

Thanks for the additional info. Your advice worked like a champ. It went just like you said with one modification. The washer and dryer only work on a 2.4GHz spectrum, so once I figured that out and moved the phone and machines to that wireless network, I was able to complete the setup. They connected to IPFire right away. No proxy issues. I was also able to move the phone back to the 5GHz connection and still control them.

FYI for any other Maytag users, the mobile app is shite, and doesn’t track with the instructions/words on the machine’s display. I also had to figure out how to clear the original wifi config on them before I could connect to the firewall (hold the “remote enable” button for 15 seconds). Once connected, you can control them remotely, but you have to enable that function each time you turn the machine on. That might be a decent security feature, but will probably get tiresome over time.

In Europe that’s not uncommon. 5.0 GHZ is capable of far more high transfer rates, but the distance is quite non-existant with enough obstacles on line of sight between the device and the AP.

1 Like