Intel Wi-Fi 6E AX210 support


I’m trying to have my wifi pci-e card (Intel Wi-Fi 6E AX210) working in ipfire (latest version).

The only mode in which the card accept to work is in 802.11gn, channel 11 (country is set to FR).
In this mode the speed is 90Mbps.

Module used by the kernel is : iwlwifi-ty-a0-gf-a0-66.ucode

I tried to install the latest modules from intel’s git, but ipfire still want to use the 66.

Anyone have been able to have this card working in ipfire ?

Note : I also do not have any values for the HT caps and VHT caps.

Thank you in advance for your help.

Best regards,

Most intel cards have a serious problem with linux. They have an flash/eeprom field with the country setting that is set to “00 - World” which allow only channel 1-11 in AP mode (I know no way to change this) this is the reason why we not suggest Intel cards.


Thanks for the info.

I was also thinking the same after a lot of research…

Do you recommand me another equivalent card (pic-e) that works well with ipfire from scratch ?

Note : I take a look on the ipfire’s wifi support page, but it’s not easy to choose a good card.

Thanks for your help.

I have no working AX card. I use an Atheros based mini-pcie AC card.

What is the model and what speed do you have ?

I tried an ubuntu 22.10 on my server and the card works by default.
Module loaded : iwlwifi-ty-a0-gf-a0-72.ucode

Speed : 780Mbps (5,5Ghz) (using default wifi settings)

When is planned the next ipfire kernel update ? Or can I use a custom kernel ?

Note : EDIT : after several tests speed range is 450 <-> 750 Mbps

As AP ? Cards in “00 - World” have no problems as client but the AP mode
(initial radio) is not working on other channels than 1-11

In some weeks an update to 6.1.x is planned but i fear that this will not help.

1 Like

Im not sure. I can check this next weekend.

My bad, no, not in AP mode … T_T … you are right.

EDIT : I will test it

1 Like