I broke my WebGUI - Need command line to activate SSH

Help! I broke my IPFire WebGUI :frowning_face:

And I am trying to regain access to my IPFire box. I’ve connected a monitor and a keyboard to my IPFire box. And I can login via root to the IPFire box and I can run commands. :smiley:

Is there a command line that I can run that will activate SSH. Basically I want to activate / click this button without having access to the GUI.


TL;DR - my IPFire box is in a cramp area, under a desk, in a cold basement. And I want to work upstairs near a computer!

Hi Jon,

Don’t know how to access the timed version. There will be a ctrl file for sshd somewhere but I don’t know where without doing a big search and it’s time for bed here.

However starting and stopping ssh from the command line I can give you.

/etc/init.d/sshd start
/etc/init.d/sshd stop

You can stop your sshd service from the ssh command line but you can’t start it obviously. For that you will need to go to the cold cellar.

Good luck.

1 Like

I found the ctrl file but it did not work…

/usr/local/bin/sshctrl tempstart 1800

I’ll try the start/stop!

if /var/ipfire/remote/enablessh file (0 bytes) exists, I think ssh access is enabled.

[root@ipfire ~]# ll /var/ipfire/remote/enablessh
-rw-r--r-- 1 nobody nobody 0 Oct 27 06:19 /var/ipfire/remote/enablessh
2 Likes

Fixed it! Thank you @bonnietwin! Thank you @pavlos!

The needed commands are:

touch /var/ipfire/remote/enablessh
/etc/init.d/sshd start

I maimed my en.pl file. So I needed to replace it and run update-lang-cache.
:stuck_out_tongue_winking_eye: