How to set ISP provided Static WAN IP?

So I moved from Florida to Texas. My previous ISP assigned a dynamic WAN IP address and I just used IPFire to update my DNS service when my IP changed. Now… I have a static IP address (facing the public) but a separate static WAN IP from the ISP. They told me I need to add this Static IP to my internal router’s setup. Well, I couldn’t find where to do this in IPFire. So I had to switch to a cheap off-the-shelf router in the meantime to get online. The off-the-shelf router explicitly has a field for “WAN Static IP Address” but uhh… I can’t find a similar setting in IPFire.

Oh and prior to this… I’ve been using IPFire for the past 8 years or so. I’m no n00b, but just never needed to set a static WAN IP.

I’ve looked through the IPFire interface, and I’ve read other posts about the Red network. But nothing with direct instructions about this setup…

1.) ISP provided a Static WAN IP address 10.x.x.x
2.) My internal network is 192.x.x.x

I can’t seem to find the section in the drop-downs of IPFire’s web client to enter the ISP assigned static WAN IP address.

Can someone just give a quick (but specific) detail on how to set it up? I already have all the 192.x.x.x with ports forwarding to servers all setup. I just need that final piece to get connected to the web.

Side note for those interested:
My ISP is a Terrestrial Antenna-based company. No cable, DSL, or Satellite. Literally a mini satellite dish aimed at a broadcast tower about 5 miles away. The way their system works is they are given a pipe of fiber connections and a “block” of public static IP addresses they can provide. They then manage those connections across their users with a 10.x.x.x network for the Static customers which essentially transfers the Public Static IP 23.x.x.x to the internal Static IP 10.x.x.x and then to my router. On my end, my internal network is all 192.x.x.x. Then to complicate things a little, I have a Mesh wireless network which has it’s own router, but I just force it into Bridge mode so it acts as a simple AP (per the manufacturer’s direction).

Your not going to find that configuration option to change the Red WAN side of IPFire in the GUI. Remember when you first installed IPFire, you went through the setup for the interfaces? That is where you have to go.

Drop to Putty and SSH your IPFire Box, hit a superuser prompt # and type setup and press Enter…

You will need to look in the above link and find the Red Interface and switch it to static, configure the IP addy, the SubNet Mask and the Default Gateway through your router. Apply the changes, reboot and it should fix you up.


…and there it is! I knew I was forgetting something! It’s been such a long time since I setup IPFire for the first time that I totally forgot about the shell-level configuration. I was so used to the GUI. Thanks! That was exactly what I was looking for.

No worries at all… Hell after 17 years of Network Engineering and Security, crap slips my mind all the time. I read your post and said to myself, yep… Made that mistake myself. LOL, hope it gets you where your going.