How to remove location not in Location Group?

Under Location Groups if the Group Name is empty and click Add, the locations dropdown is shown and you can add locations to the empty group. The group and locations in the group cannot be removed or deleted.

Network/Hosts Groups and Service Groups don’t allow for a blank group name

1 Like

Hallo @kat3

Welcome to the IPFire community.

I can confirm the issue you mention. That is definitely a bug.

It would be good if you could raise this as a bug in the IPFire Bugzilla. Your IPFire People email address and password will act as your login credentials for the IPFire Bugzilla.

To fix the issue in your system you can edit the appropriate file via the terminal console.

The file to be edited is

My test file with a normal group and one without the group name had the following contents

2,testing with blank name,AO,Location Group
1,testing,ES,Location Group

In the WUI it looked like

You can either remove the line for the group with no name, in which case the entry will no longer show in the WUI page or you can add a group name into the line as here:-

2,proper group name,testing with blank name,AO,Location Group
1,testing,ES,Location Group

and this now shows in the WUI as

Befor you raise a bug.
Make sure the group is not in a active firewall rule.
Then try to remover location from location group.
This one got me.


That is what won’t work. I created the location groups and did not use them anywhere but without a location group name the entry only has the flag with AO Angola in my test case and there is no pencil or dustbin icon to edit or delete the location group.

@kat3 is correct that if you try and create a Service Group or a Network/Host Group and leave the Group Name empty when you create it then you get an error message telling you what characters are allowed for the name.

For the Location Group if you leave it blank then the code accepts that and saves the result but now the cgi code for the WUI page fails to display the action icons for that group.

editing the file fixed it, my path was /var/ipfire/fwhosts/customlocationgrp

1 Like

Glad it worked for you. No idea why i put /var/run instead of /var/ipfire. That was an error on my part but glad you figured out the correct path. I have corrected my original post.

The fix for the problem has been merged into Core Update 179 which should come out for testing before too long.

1 Like