How do I disable log coalescing?

How do I disable the use of “last message repeated X times” in syslog?


The file /etc/rsyslog.conf has an option, $RepeatedMsgReduction on
Change it to off and it will show every line.

My installation (core145) does not use rsyslog, is that a recent change? In any case, there’s no options like that. Here’s my syslog.conf:

# Log all kernel messages to the console.
# Logging much else clutters up the screen.
#kern.*							/dev/console

# Log anything (except mail) of level info or higher.
# Don't log private authentication messages!
# local0.* any dhcpcd log (even debug) in messages
cron.none;daemon.*;local0.*;local2.*;local5.*;*.info;mail.none;authpriv.*	-/var/log/messages

# Log crons
#cron.*										-/var/log/cron.log

# Everybody gets emergency messages
*.emerg										*

# Display logs on tty12
*.*												/dev/tty12

# Optionally log to a remote host
*.*											@

# Postfix logs
mail.*										-/var/log/mail

# HAProxy
local1.*								-/var/log/haproxy

Your syslog is correct (although you should upgrade to ipfire core 150). I do not think there is an option to disable the compression of those messages. My ipfire core 150 has the same /etc/syslog.conf

There is an option in rsyslog, which sends your log to a remote server.

I have the logs forwarding to a remote rsyslog, which is the main reason I care about this. The combined messages lack details I need to properly process the messages. In the context of aggregation, this is just noise, and I’d rather eliminate it at the source rather than throw them away in rsyslog after they’ve already been forwarded.