Hostnames on green network not recognised

On my green network, I’ve allocated fixed IP leases (mapping from MAC address to IP address) for all the devices we use - about 20 of them, counting the wired & wireless addresses for laptops. I thought it would be nice to give each device a name, to save having to use the numeric IP address to define them. However since I edited the “Domain Name System” page to use TLS to the Google DNS server, to get round a problem with my ISP’s DNS server, any attempt to access a device using its hostname, either as the plain hostname or with the local domain xviipylehill.net added, fails - I’ve tried both pinging from the command line and access using a web browser, and get an “unknown host” error. The hostname page lists all the IP addresses in our network, each with its hostname, the domain name xviipylehill.net and the PTR box ticked.
Can anyone suggest what I’m doing wrong please?
Thanks
Ian

suggestion: stop/start DHCP and restart unbound

/etc/init.d/dhcp stop
sleep 2
/etc/init.d/dhcp start
sleep 2
/etc/init.d/unbound restart

Try adding the IPFire green address to the list of DNS servers on one device, then see if it can find the other devices.

Your problem might be similar to the one in this thread Issues with HOSTS while upgrading from 139 to 144

Thanks very much, @pavlos - that worked :smiley:

Really? It was me who started the above linked thread.

This means the issue is existing within other installations, too. Good to know, at least for the devs…

Thanks for your feedback! I will link this thread to my posting…

Michael

Sorry, @hellfire, for any confusion. I thought I’d try the solution in @pavlos’ reply first - I didn’t look into the thread which you referred to. When @pavlos’ suggestion worked for me, I didn’t dig any further.

Thanks all for your suggestions.

Ian

I’m not convinced that the two issues are the same.

@hellfire was using DHCP for clients on GREEN, whereas @quasimodo41 is having a problem when not using DHCP and notes that PTR boxes are ticked.

I’m afraid @rodneyp misunderstood my original post. The clients on my green network do use the DHCP server on my IPFire box; I’ve defined a fixed lease on the IPFire DHCP Server page for each client’s MAC address, so that each client always has the same IP address.