Help to config ? ( noob / first start )

hello , a bit noob here
installed ipfire-2.27.2gb-ext4.aarch64-full-core162.img on raspberry pi 4 4gb ,
this iso start ,
i followed how to ( for start ,but still no work )
i dont know how to put picture ,

internet router :
dhcp : on
ip 8x.14x.29.11
bridge 8x.14x.28.1

my pc auto/dhcp on :

network : green + red
green usb tp-link = plug to swith ( pc )
red “of: bcmgenet” = plug to internet box

interface green :
ip adress
network mask

interface red
(*) dhcp
dhcp hostname : ipfire

done , done ,
restarting network

reboot ,
all is ok in green ,
only time is warn ( raspberry dont save time )
later ipv4 table do not exist ?? ( but no color idk )

and i have no internet ,
ipconfig /renew on cmd windows ( get new ip )
i dont have new ip
device not conected …

i go on isp box , i see my raspberry pi with ipfire

why dhcp still dont work ?
normaly my computer have to get ip like no ?
any one can help ?

check out the installation from wiki and you should be able to find your answer there. I think step 4 - initial setup is what you need. if you do see the initial setup screen on the terminal, just type setup and follow the instructions. Good Luck.


i have for red

after i ok , done , done and get a reboot

5a - missing step dhcp setting dont have

i dont have this step ,
missing dhcp for green , any command to get it ?

Have you configured your green interface?

1 Like

for green , no any option , just this :

i folowed this how to , step by step
yes , like on picture

local :
dhcp enable , mask
ip start to 50

( i tryed apt get update && upgrade , but command unknow … )

You have a picture showing Restarting Network.
This is only shown when you are running setup and not when you do the installation.

The dhcp server screen is only shown during the installation and not during the setup.

If you have already completed the installation then you should be able to access the IPFire WUI from a machine on your green network and you can adjust the dhcp server from the WUI page.


Your last picture isn’t from IPFire.

As Adolf wrote, DHCP config is called during installation only. I just verified by looking into the sources.
In a running system you can reach the DHCP config by the WebGUI ( in your case ), Network → DHCP server ( directlink )


i have not answers

cant acces / page no answers.

:upside_down_face: sorry about dust …

red = raspberry = ISP modem
green = TP link = local network

that’s what i have in the setting…
i dont have acces to interface

plug wire from switch to box ( for get internet )
on my box i have lan
ipfire (1000 Base-T) / 1Gbp

same : no awnsers

What is this net?
Green ( LAN ) of IPFire is, based on your earlier posts.

What is the situation, when you set your PC to ( just an arbitrary IP from the green net ) statically. For the base config you can connect your PC directly to IPFire.

1 Like

rebooted pc ,
tryied to plug pc wire to raspberry : nothing

unplugg red from internet box , and i got interface …
tryied to plug red on internet box and now all working …
:joy: dont ask me , i dont know what i do …
but it work …
any way to backup everything ? xD

:kissing_heart: :kissing_heart: :kissing_heart: :kissing_heart: :kissing_heart:
kiss you alot for help…

going to see what to do now for general rules for safety
safe to update it ?
i tested few version of iso , but still never boot before this version

last question , what the probleme with password ?
i put basic password for install ( on linux / raspberry )
and changed password for interface when i got acces to interface ok
but now on linux ( raspberry with keyboard )
no one login / pass work :confused:
password from interface overwrited pass from raspberry …
just login change …

The passwords for the console shell and the WebGUI are different, and independent.
What did you exactly do?
What is your IPFire version?

check top : installed : ipfire-2.27

i have put poor login/pass on linux root/root admin/root
when it work ,he ask me new pass for

i put a strong pass ,
interface say me update is here ,i updated it
and now the new strong pass is for interface and for raspberry …
the poor root/root no work …

What is ‘interface’, what is ‘raspberry’?
It is a bit difficult, if we do not use the same names for devices.

As far as I’ve understood, you have installed IPFire on a Raspberry hardware.
IPFire has two main interfaces for administration:

  • the console with keyboard and monitor or via SSH, user root
  • the WebGUI accessed through a browser, user admin

Both have their own password, which can be changed separately ( with ‘setup’ only ).

1 Like

hello , yes i say the opposite ,
when i start setup , yes ip fire asked me password for root ,i put root
and asked me password for admin , i put root too …

when interface work on my computer , ipfire asked me to put strong password for admin
i put strong one , work with admin+strong one

but on raspberry , root + root , dont work anymore
now it’s root + strong one …

surprise …

If you can reproduce this, you should make a ticket to bugzilla.
Your credentials for the community are valid there also.

I couldn’t find the password handling, yet. So I have no idea what may be go wrong.
But the core devs access bugzilla more frequently than the community. Maybe some of them know more.

EDIT: I just tested the case. I cannot reproduce the issue.

  • set the admin password to root ( with setup )
  • WebGUI requests a new authentification, admin:root accepted
  • logout from shell, relogin to console with root:<oldpw_r>, accepted
  • change the admin password to the old value
  • WebGUI requests a new authentification, admin:<oldpw_a> accepted
  • relogin to console with root:<oldpw_r> is possible
1 Like