Having trouble with getting setup

Greetings to all,
I have come here to the IPFire gurus here in the community to see about getting some assistance in getting my ipfire setup and running. I am running IPFire as a virtual machine inside VirtualBox.
My goal is to set up a small internal network using the Red/Green/Orange configuration. I hope to have a internal green network and an orange DMZ.
I have ran through the installation several times and I am never able to get access to the web UI to further configure the firewall rules and set up the DMZ. I do not understand what I am missing… I would be happy to post any details or information about the post installation necessary.
I have comcast cable internet, which is wirelessly hosted to my home network, and my laptop (running Windows 10 pro) is connected to that. After completing the installation of IPFire, and assigning the 3 virtual NIC’s (bridged adapter(red) internal network x 2 for green and orange) I am able to ping google.com successfully.
Any help and insight into how to solve this issue and move forward would be greatly appreciated!!
Thank you,

Hall @redwhitenblue

Welcome to the IPFire community.

Where are you trying to access the WUI from. You should be doing that from a virtual or real machine that you have installed connected to the green network. If you want to do that from your host machine then you would need to create a firewall rule that will allow your hoist machine to access the IPFire wui from the red interface.

I have a vm testbed set up using virtual box as you are describing. The only difference is that I have red/green/blue/orange set up. I access the IPFire wui from one of the vm’s running on green. I have not set mine up to access the IPFire wui from the host machine running virtualbox which is the red interface as far as the vm IPFire is concerned.

In my case I have set up two arch linux clients on green, two on blue and two on orange.

Just to confirm, you have installed virtualbox on your windows 10 pro laptop and you have then installed IPFire into that virtualbox installation. Do you have any virtual machines installed on the green interface?

Hello @bonnietwin ! And thank you for your speedy reply!
Yes to confirm: I have virtual box installed on my laptop running windows 10. Then inside virtual box I have 3 VM’s running AlmaLinux on the green(internal) network. I have IPfire installed as a separate VM within VirtualBox as well.
I have tried to access the WUI from a MS edge browser on the windows laptop and get nothing, and I have tried to access the WUI using Firefox from one of the AlmaLinux VM’s within VirtualBox on the green network and also get nothing.
Im glad that you have something similar set up because you know what im working with :slight_smile:
Can I ask: In VirtualBox what should my main adapter look like? Right now I havea HostOnly Ethernet Adapter configured automatically and I have DHCP server enabled. Does that sound correct?

For the red interface of my IPFire vm I have the interface set to Bridged Adaptor and the name being the interface name of the nic on your host laptop. In my case that is enp4so because Arch Linux renames the interfaces. Yours might be eth0 or something similar. The name dropdown box in the Network section of VirtualBox will show you the available options.

Then my adaptors 2, 3 & 4 are Internal Network and named green blue and orange.

Probably best to just concentrate on green to start with and with just one green vm. Once that is working with the wui then you can clone copies of that and just change the mac address of the network interface.

The Bridged Adaptor option allows your IPFIre vm to access the laptop network and hence its internet connection.

Glad to be of help. As long as there are no problems related to windows as I am only using Linux for the last 15 or so years. Other than that, I will help as much as I can.

Thank you @bonnietwin
I am a bit confused about the adapter that VirtualBox uses to talk with my outside connection. The one that you access in VirtualBox under the ‘Tools’ option. I have it as VirtualBox Host-only Ethernet adapter with automatic settings and DHCP server enabled. Does the configuration sound right? I am rebooting everything and I am going to try to access WUI on the AlmaLinux VM now. Does the order in which I boot matter? Like boot IPFire VM first then the Linux VM on the green network or vice versa?

I just get unable to connect on the Linux VM that is on the green internal network. :frowning:
When I boot the IPfire VM it loads up fine, everything gets a green ‘OK’ status. The green internal network I have named the card ‘green’ so it shows green0 : 192.168.x.x for the address. That is what I plug into the browser on the Linux VM and get unable to connect.

I haven’t touched that at all.

In the vm settings for IPFire there is a Network section as shown here.

If you click the Network line then this screen will be shown and I have set up the Adaptor 1 as shown here for the red connection of IPFire.

I just let VirtualBox choose the MAC address for me.

What does this screen look like for yours. You will probably need to just describe it because new community members are restricted on providing screenshots for a period of time to prevent spammers etc.

Here is what I have for the entries for the Host-Only Networks. Although it is shown as Configured manually it was still done by VirtualBox. I did not set anything here.

hello @bonnietwin .
Thank you for your replies with pics!
I wanted to give you an update on my endeavor:
I did a fresh install of AlmaLinux, making a new VM. I had IPfire VM running during this time, and when I completed the install I logged in and fired up Firefox and the WUI came right up! So, I’m thinking something was screwy with the other VM.
Now it should be pretty straight forward to set up my DMZ I would imagine. Any tips in that department? Thanks again for your assistance with this.

I am glad you got it working.

Regarding the DMZ, the main thing to remember is that IPFire does not provide DHCP or DNS services to the Orange zone.

Therefore one vm in your Orange Zone has to have a fixed IP address and have a DHCP server installed.

That computer always needs to be turned on first in the Orange Zone.

In the dhcpd.conf file on that computer you will also need to define the external dns servers to be used for computers on the Orange Zone.

1 Like