GRUB error on 149 upgrade

Hi, after upgrade from 148 to 149 get in boot:

error: symbol ‘grub_file_filters’ not found

I use for IPFire system a laptop Envy M4 with Intel.

Help! Thanks in advance.

1 Like

Hi @fiodor.

I once fixed a boot problem by following these steps (I don’t know if it will work for you):

Once in the Linux boot list, press the “c” key for advanced boot and put these 3 lines.

grub> set root=(hd0,1)
## grub> linux /vmlinuz-4.14.72-ipfire root=/dev/sda3 <-- Example
grub> linux /vmlinuz-(versión del Kernel)-ipfire root=/dev/sda3
grub> boot

It will start and a downgrade can be done by modifying the “mine” file from /opt/pakfire/db/core, for example 148

Next, pakfire update and pakfire upgrade --force.

This should repair the startup.

Tell Us something.


Thanks @roberto, but there’s no boot list, just a black screen:

Welcome to GRUB!
error: symbol ‘grub_file_filters’ not found.
Entering rescue mode…
grub rescue>

And when trying boot:

grub rescue> linux…
Unknown command ‘linux’.

Will reinstall IPFire from ISO.

Hello @Fiodor,
i have the same error on Zotac Zbox CI329 nano after upgrade and reboot.
Reinstall with 149 ISO same error after first reboot.
Changed the harddisk and reinstall 149 ISO same error after first reboot.
Reinstall with 148 ISO works again.
I will not upgrade to 149 now and wait for 150 and hope this issue will be solved.
Might be an controller problem.

Have you tried to switch between uEFI and Legacy (CSM) mode in the uEFI config? IPFire support both but in core149 we have updated grub. Maybee there is an incompatibility in one of the modes.

1 Like

thanks a lot for the fast answer,
as supposed after upgrade to 149 and changing BIOS to lecacy mode, reboot works as expected
so thank you very much again :smile:

Yes, when installed IPFire in UEFI mode was the problem on upgrade from 148 to 149, but installing from ISO 149, in legacy mode, there’s no problem.

Same problem with possible fix here: Dell Wyse Z90D7 - Won't boot after core update 148 ->150

Hi @arne_f

this change of grub during the update was stressful and problematic for me:

After the update and reboot, IPFire did not restart … I was connected remotely and my customer’s entire network was offline.

Not possible to troubleshoot other than to take my car and come to the customer’s site … Fortunately it was not several hundred kilometers !

The solution : Locally, simply change a parameter (UEFI to legacy) in a bios…(!!!) Isn’t there another solution to avoid it ?

1 Like

Grub is always a bit tricky. We have updated it because newer boards based on Celeron N41xx will not boot at all with grub-2.02

Also on all my systems IPFire boot in both modes so i think it is a bios/firmware bug that was triggered by the new version.

@arne_f, I understand that things are not always simple, I trust you completely on the legitimacy of this change of grub.

It just seems a bit of a shame that for some “sensitive” updates there is no message warning the user about the potential risk, or display a criticality level…

In my opinion, there is no worse than an OS boot problem

Today during an core update, it’s a bit like “do, wait and see …”