Graph for latency to gateway gone blank after Core Update 158

I thank the ipfire project team for their work
I updated ipfire to vertion 158 and noticed a display problem on a graph.

what are the firewall rules to restore the graph
thank you

Hi @gw-ipfire

Welcome to the IPFire community

Is it just that one graph you are having problems with or all graphs?

I have updated my system from 157 to 158 and all the graphs, including the gateway graph, are showing everything as before.

Did you do a reboot. Although it did not say that a reboot was required, I tend to do one as standard after an upgrade.

1 Like

just that one graph
I have reboot the same result again

the gateway graph uses which protocol or port to verify the connection with the gateway?


plain old ICMP (type 8 for ping).

Are there any errors in /var/log/messages, especially related to collectd?

Thanks, and best regards,
Peter Müller


i have look /var/log/messages no error
i have this firewall rule

its ok?
i have test with log acive i see icmp request in firewall log
but the graph no good

What is the reason for this rule?
It produces the issue you describe indeed.

I thought this rule was good
Should I delete it?

If the only reason is ‘good’, delete it. :wink:

ok I delete

i have delete rule but graph no work
i have reboot ipfire

I tried with your rule.
While the rule was active I had messages about rejected ICMP packets and also the collectd message collectd[2735]: ping plugin: ping_send failed: Operation not permitted
After deletion of the rule the FW messages are gone and the collectd message reads
collectd[2735]: ping plugin: ping_send succeeded.

During definition time of the rule there was no graph ( collectd had an error ). Without the rule thr graph is active also immediately.

I suppose you have another problem. Can you ping your gateway from the shell?

i have ping_send gateway no results in terminal
i have look log firewall i have this message

When you deleted that rule did you also press the green Apply Changes button at the top of the page?

yes i have Apply Changes button i have reboot ipfire
i use drop general option in firewall

Which option do you mean, where?


then you have to define rules for all allowed protocols/ports. In case of gate latency ICMP(8)

yes that "s why I had made the red icmp8 rule I saw alerts in the firewal log and I didn "t have the graph for the gateway anymore I thought that would solve the problem

Sorry, my fault. I didn’t look exactly at your rule.
I assumed a standard installation ( LAN devices are allowed to access the internet without special rules ).
In your case the rule is necessary to allow ping requests. But I think, it is necessary to define a rule for the incoming ping replies also.