First steps by using V-Lan

Hello everybody,

last week I tried to configure V-Lan at my ipfire. But I think, I misunderstood something…
I activated V-Lan on blue interface. I assigned the ID “1” to the V-Lan

. Hardware is a Netgear JGS516PE, a Zyxel MWA5121-N and some NWA1123-ACv2. They are all configured to the correct ID, the Netgear is tagged at the concerned ports and I can connect to the V-Lan via W-Lan.
But how can I configure a DHCP to the V-Lan(s)? How can I set the rules to ipfire?

Maybe, it’s would be a simple problem caused by my zone configuration. But, how I told, this are my first steps…

Thanks for your help

I do believe Vlan 1 is the default for most switches, some companies refer to it as the management Vlan, mine is a different brand then yours but I can’t even change Vlan one, and it starts at 2 for adding new ones.

Try anything other then Vlan 1, you will need to add a new Vlan table.
As far as DHCP goes if the Vlan on Blue is configured and working correctly then under Network then DHCP you can configure the options there for Blue DHCP also, it has to be a different network then Green.

Also Note if using Orange with or without Vlan there is no option to have DHCP on it from IPFire.

Hello and thank you for your hint!

I was happy that it was so easy to be …
After taking the advice into account, nothing worked. Maybe you can help me understand the tutorial:
If I set the zones to “Bridge”, does the ipfire expect me to set a second NIC in the same zone to “Bridge”? Or is that a bridge between the “normal” Lan (ID1) and my V-Lan (ID10)? What’s up with the MacVTap? It is supposedly no longer supported, but is still available !?
I ask for it, because if I just change the corresponding NIC for the zone from “native” to “VLan”, nothing works anymore. After changing this to VLan it’s possible to select an ID underneath, but if I forward this ID by my switch, then nothing arrives at the client. And the “normal” LAN in this network is then no longer available …

1 Like

Hello Stefan,
first of all, I am not an expert. I found this thread because I have a similar problem. I don’t have an answer to the first question about bridges.

In the wiki is written “Note - Support for macvtap has been dropped as of Core Update 156. Please use bridges instead.” But the currently released version is Core Update 155. So I expect it will be removed with the next update.

Yeah, thats exactly my problem. My GREEN zone has only one NIC which is currently set to “Native”. When I change it to “VLAN”, nothing works anymore. When I check the messages during IPFire Boot sequence I see:
Bringing up the green0 interface...
Interface green0 doesn't exist. [ FAIL ]
No LEDs are blinking on that NIC anymore.
So for me it seems to be a problem with IPFire and not with the configuration of my switch.

So, is your NIC at the IPFire computer assined to (in your case) BLUE still working?
Can you narrow down the problem? If it is a problem with IPFire or with something else in your network?

I don’t want to hijack your thread.
I am just curious if we have the same problem or not.