External usb hdd spin down


I have 2TB external usb hdd attached to ipfire. On this hdd is shared folder - smb.

Disk is making noise, and never spin down. Even when nothing is connected to smd share. I tested two external hdd, both spins down on windows, none in ipfire.

Is there any solution how to spin down usb hdd.

And yes, external drive graph shows that hdd is idle, but in reality is not.


Not all the disks respond properly to hdparm. Maybe this is the problem causing your issue.

Does the following command from the console spins down the disk?

hdparm -y /dev/sdX

where /dev/sdX is the name of the disk device. You can find all the disks device name in your system with lsblk.

Careful, this command should spin down the disk, therefore do not issue it while writing on it, as it will lead to data loss.

1 Like


hdparm -y /dev/sdc

I get this response:
issuing standby command
SG_IO: bad/missing sense data, sb[]: 70 00 05 00 00 00 00 0a 00 00 00 00 20 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

no luck.

Disk is WD caviar green.

I found this thread pretty much explaining your issue.
Basically, the combination of the hard disk firmware and enclosure are frequently buggy, in particular in the SATA-USB bridge which stratify two layers of communication channels (SCSI and USB) that the ATA commands have to transverse to reach the disk.

You should read the entire message and also this answer.

Beyond that, the topic gets way above my head. My only suggestion is that you could consider opening a bug report so the developers might help. Maybe they can tune up the firmware, as the Ubuntu users did in the tread I linked above? @arne_f or @ms , some suggestion?

The Linux usb storage subsystem doesn’t support sending direct ATA commands to the drives at all.

smartmontools work arround this by accessing the usb bridges via direct access but hdparm doesn’t support this. So at the moment setting usb drives to sleep is not supported except the drive support itself.


Swaped enclosure for 15 years old Fujitsu-Simens USB2 eclosure with 10 years old WD caviar and it respond to hdparm -y /dev/sdc (stadby), and hdparm -Y /dev/sdc (sleep).

Sometimes go to standby by itself after 40 min., sometimes not.

It is not USB3 speed, but better than nothing.

1 Like

Is there any hdparm.conf file in IPfire like in Debian?


No there isn’t.

that’s to make the change survive at reboot. However, you can test if it works by using the /sys interface of the kernel, as discussed in that thread. At least you know that what is discussed in that thread is the same problem you are having. If yes, you can use rc.local to issue an echo to the sys interface at boot.

Out of experience, i will breake system multiple times. ;-)))))
Thx for help, now i am satisfied, 40 min interval seems to work.

A little fun:

wd.com site no longer has support for WD Caviar Green. Earlier, it pointed out that the drive has firmware that will spin it down after a few seconds of inactivity. WD Caviar Green were intended as only occasional use backup drives.

Regardless of whether or not you are able to resolve the issues between enclosure and drive, WD Caviar Green is not suited to your application. If you persist with it, then it is likely to use up its stop/start life in short order.


I wonder if the information on the following page will be helpful.




more info here, including the tools to change the firmware setting.


Yes,Yes, load cycles are growing like crazy.
193 Load_Cycle_Count 0x0032 103 103 000 Old_age Always - 292502

I will try this.

WD rate the Greens for 300000 load cycles.