Error while booting after update from 156 to 157


yesterday i started the installation to core157 on my ipfire. Everything seemed fine and after that the system needed a reboot. After that, no connection to the web ui was possible but the internet connection worked. So i decided to connect a monitor to the system an saw the following error message:

/etc/rc.d/rc3.d/S29collectd is not executable, skipping.
/etc/rc.d/init.d/rc: line 93: /etc/rc.d/rc3.d/S29collectd: Permission denied

You should not be reading this error message.

It means that an unforseen error took place in /etc/rc.d/rc3.d/S29collectd, which exited with a return value of 126.

If you’re able to track this error down to a bug in one of the files provided by ipfire, please be so kind to inform us at

I also noticed that no openvpn connection is working from outside the network to the ipcop.

Is there a way to repair the system?

Edit: added photo:

What do you get for
ls -l /etc/rc.d/init.d/collectd

It should read:

ls -l /etc/rc.d/init.d/collectd
-rwxr-xr-- 1 root root 4295 Jun 18 12:49 /etc/rc.d/init.d/collectd

seems to be ok

… but this is not ok:

While waiting here for a possible solution I tried the following:
I set up a new PC, equipped it with two network cards and installed the latest 157 version. After that I restored the backup I made in 2017 after the last complete setup. However, I can’t get to the web interface after that. Possibly the backup is too old? Anyway, I can’t get anywhere with it either. I hope someone has another idea. Otherwise I would have to exchange all VPN certificates. Thanks a lot for any hints!

Hi @v952560

Your second screenshot indicates that somewhere during the update from 156 to 157 there must have been some file corruption occurred as the symbolic link for collectd in your rc3.d is missing.

I had no issues when I ran my update from 156 to 157 on my production system or my testbed vm’s. The collectd symbolic links are all present in rc0.d, rc3.d and rc6.d

The simplest solution is to recreate the symbolic link if you are comfortable with the command line.
The mv command is just as a safety precaution but I think your link is a dangling link that is not pointing anywhere.

mv /etc/rc.d/rc3.d/s29collectd /etc/rc.d/rc3.d/s29collectd.orig
ln -s /etc/rc.d/init.d/collectd /etc/rc.d/rc3.d/s29collectd

Also check that the collectd symbolic links are there in rc0.d and rc6.d

Once everything is working again then you can remove the s29collectd.orig file that was created.

1 Like

That is rather a long time since your last backup. 4 years would have been somewhere between Core Update 104 to Core Update 111.

I would recommend doing a backup more frequently but IPFire does an automatic backup (without logs) as part of the Core Update. So you should be able to find that backup in


So you can also use that backup for your restore if the recreation of the symbolic link does not work.

1 Like

Hi @bonnietwin

Ty for you replies! I tried your suggestion and checked also rc0.d and rs6.d:

…and after rebooting the error was gone but there is a new one:
Sry. can only post one picture because I’m a new user…

So more files have been corrupted.

So /etc/collectd.vpn should be a symbolic link to /var/ipfire/ovpn/collectd.vpn if you are using OpenVPN.
You mentioned VPN certificates so I suspect that you are using OpenVPN but would be good to confirm that as yes and not IPsec VPN.
Following is on basis of OpenVPN.

I would first check the permissions etc of the target file

-rw-r--r-- 1 nobody nobody 84 Jan  7 17:20 /var/ipfire/ovpn/collectd.vpn

If it is the same as above then read the contents of the file and check if they look like the following.

Loadplugin openvpn

<Plugin openvpn>
Statusfile "/var/run/ovpnserver.log"

You can also check from your backup what the contents of collectd.vpn are. I would look in the backup that was created by the Core Update 157. The .ipf file is just a compressed tar file. You can look at it with an archive viewer program. The file will be located in the archive in


If the content of the backup matches what you have in the file on your system then you can remake the symbolic link.

mv /etc/collectd.vpn /etc/collectd.vpn.orig
ln -s /var/ipfire/ovpn/collectd.vpn /etc/collectd.vpn

If the above does not solve the issue or another corrupted file is discovered then I think your best option would be to do a re-install and then restore from the backup that the Core Update 157 upgrade would have created. Download that backup file from your IPFire system before doing the re-install.

It might be worth running a check on the disks and the memory of your system to make sure that the hardware is all okay.


I would recommend that, too.

1 Like

Yes, that’s right.
The file /var/ipfire/ovpn/collectd.vpn had the right permissions and looked fine.
I remade the symbolic link and restarted. The error is gone, but the web interface and vpn connections still not work.

I copied the backup files to an usb stick and make the re-install on a new platform.
Thanks anyway for all the help! I learned a lot and am very happy about this great product!

1 Like