Error the requested url could not retrieved

How can I solve this problem, I’m using a web proxy, when I search the site it goes to this url and returns the mistake.

The message indicates that there is a problem when trying to access that web site.

I did not try the link out as it has .exe in the url so I definitely wouldn’t try that url from a windows machine but I didn’t want to try it from the my Linux machine either.

The following link does work so it looks like there is a problem with the url you are trying to access. Are you sure you have accessed the correct url. If the url is the correct one and is failing then you probably need to contact the web site owner.

Do you also have the URL filter turned on with your web proxy and have the Block Executable Files checkbox selected. Maybe the .exe in the url is triggering the block. If it is then I would suggest first finding out why there is the .exe in the url before removing any of the blocks in the web proxy/url filter section.

thanks for your attention friend, but the url is correct, and in the url filter the extension block is not active, that .exe I found strange but it is a parameter for the search because it searches for files, I deactivated the url filter but it did not work, I am paralyzed in problem.

I set up a vm IPFire together with a vm Arch Linux system on green. It is set up with the Web Proxy running but no url filter and with Intrusion Prevention turned on and Location Block turned on for all countries.

I then entered that url in the SeaMonkey browser running on Arch Linux. With the proxy set to the system the url opened without any problems.

With the proxy on SeaMonkey set to use IPFire I got a similar error screen as you showed.

Looking in the browser console for when that url is accessed with the proxy the following message is found.

GET [HTTP/1.1 502 Bad Gateway 1028ms]

So the web site seems to be giving out a bad gateway response which the Squid Web Proxy does not like, presumably because it is expecting a gateway response.

You will either need to disable the web proxy or add the domain name for your url to the browser proxy exclusions list or add it to the IPFire web proxy domain exclusion list.

To get the url working with the web proxy would require the web site owner to correct whatever the gateway error is.

On the SeaMonkey browser in the proxy set up page I added into the “No Proxy for:” box and that page opened up successfully so that is a way to maintain your web proxy for most pages but just exclude that defined top level domain.

friend I configured it in the browser’s proxy and it opened, but in iPfire I’m having doubts where is the correct place to put it, I’ll send the print and help me if it’s right.

You have added it to the URL Filter. That is incorrect as the problem exists even if URL Filter is not enabled.

There are two options.

One is to use an ACL (Access Control List) command in
/var/ipfire/proxy/advanced/acls/include.acl as per

The problem is to figure out what ACL command to use. I have never used ACL’s with the web proxy and I have no idea what command should be used. Maybe other people can help with this topic.

The second is to add the domain exclusion into the WPAD/PAC File and use this to define the proxy selection in your browser.
You would then include the domain to be excluded in the “Excluded URL s (one per line):” box in the Web Proxy Auto-Discovery Protocol (WPAD) / Proxy Auto-Config (PAC) section of the Web Proxy WUI page. That exclusion will then be included in the generated pac file wpad.dat

Thanks for the tip friend, I’ll study how to solve this.