Error messages when assigning static DHCP leases

Good day, I have just installed IPFire and so far really enjoying it, as I am a previous Smoothwall user, so I love the simplicity of IPFire’s WUI. However, one small issue keeps popping up:
When I assign a static (fixed) IP lease of to my PC, I get two error messages, one in orange and one in red.
First error message, in orange is “IP Address outside subnets”
Second error message in red is " Fixed IP Address in dynamic range"
However, my dynamic DHCP range is from to so I am not sure why I would be getting these errors. Obviously, when I remove the fixed leases the error messages disappear… I hve tried restarting IPFire box after makng changes to the DHCP server nut error messages still persist.
Canyone please assist in how to go about removing these messages and possibly explain why they are apprearing so I can understand the cause in order to avoid future issues?
Thanking you.

Hi @markadewet

Welcome to the IPFire community.

Could you please take a screenshot of your DHCP Web User Interface (WUI) page.

As you are a new user then you may be limited in being able to submit a screenshot in which we will have to ask for each of the bits of info from that page to be able to figure out what is happening.

1 Like

@bonnietwin Sure, here we go, sir. First one.

Second one:

Thanks very much for the screenshots. Those helped greatly.

Problem is solved in that you don’t have a problem.

Those two messages are the legends.

Here is an example of my setup that specifies some IP’s that are outside of my green and blue subnets.

It is the line of the Fixed Lease itself that is highlighted in Orange or in Red.

I have noticed examples of these messages are not clearly enough shown in the wiki page, so I will add some screenshots in to clearly show what would be seen for both situations.

Looking at the screenshots also helped me notice that the “Disabled (click to enable)” legend is not next to its blank checkbox icon. It is shifted to the right.

I will also look at fixing that issue with a patch.


@bonnietwin Thank you, sir, glad to know it’s not actually anything to be too concerned about. Thank you for prompt replies and assistance. Have a great day further and all the best for 2024!!

So it is not mistaken as an error message, it might help to do something like this in the Legend:

(but without the periods in the orange and red areas)

1 Like

We can’t consider all problems of users in reading.
The row is located in chapter ‘Legend’, so it is clear that this are no errors but descriptions of possible error lines in the table above.
Just my opinion. :wink:

1 Like

@bbitsch With all due respect, sir, it’s not a matter of “reading” or “not reading”. As explained, I am new to IPFire and errors like these are a complete surprise to someone who has never worked with IPFire before. Secondly, I have searched for this chapter “Legend” in the wiki, without success.

@markadewet , sorry if I was bit to harsh. :hot_face:

But this thread belongs to the category ‘if you had read the docs ( wiki ), the question would be answered’.

I just looked at the wiki entry. It’s true the colouring isn’t explicitly described. The (older) screenshot of the fixed leases definition shows the legend part clearly.

BTW: It’s true that not all parts of the wiki are really up-to-date, especially the pictures. On the other hand each registered user of the community can edit the wiki. This establishes the process new user corrects a field learneddevs/mods review this and supose correctionsbetter documentation.
The alternative ( devs do all the doc ) binds much more resources, which could be invested in development.

@bbitsch Apology accepted although not necessary, I did understand your point. Thank you for confirming that the wiki entry is not there as well, I am happy it’s not just an old man (me) not looking properly issue!! LOL
As regards editing the wiki, let me look at that first, I am definitely NOT willing to make a mistake on something that to me looks pretty comprehensive already.
Thank you.