Error http:443 in Proxy-Protocols

Hello everybody, my name is Chris from Germany and this is my first post. I run a “fritzbox - ipfire - switch - win10pc” configuration as shown here:

I use the web-proxy with url-filters, and since a few days a strange error occurs in the proxy-protocols: http:443, up to a dozen in a row. This one is from another Windows 10 PC with the IP

I used wireshark (installed on to investigate, but I couldnt find out what packets caused this.

I checked my configuration, but I simply cannot find the reason for this. The only thing i am not sure a 100% is my DNS configuration. Is it ok to add my fritzbox as a dns server in network > dns on the ipfire, or is this a mistake. If yes, what would be the right way?

So it would be great if you could give me a hint. I run the current 155 version of IPfire on a physical appliance.

Thanks so much,

Hi ChrisW,
I know nothing about the fritzbox but changing DNS on IPFire 155 is very easy, try pointing it directly to cloudfare and see what happens if you think it is the issue.
It may even reduce some latency?

Hi @homercide , thanks a lot for your answer.

I think i found the reason, is has to do with a squid error: “transaction-end-before-headers”
Does anybody have a hint for me regarding this error?


I did a google search for

It brought up many cases with this issue and not specific to any linux or firewall build, it will prove to be much reading for you, some seem to point at people checking their Gmail and SSL, it is all over the place. Maybe try looking at the browser settings on the pc creating the log entries?