Error after Update to 159… IPFire not booting anymore

The Update to 159 ruined my ipfire-system…

Error
Not a correct XFS inode
Error
File /grub/i386-pc/normal.mod not found

Whats next now? Someone “at least” an idea, what to do next?

Never mind…

Looks like your grub installation was corrupted by a file system error.
You can try to boot the system with a SuperGrubDisk2 and try to reinstall the bootloader.

https://www.supergrubdisk.org/category/download/supergrub2diskdownload/super-grub2-disk-stable/

2 Likes

Hi,

first, sorry for breaking your machine. There were some few users who reported similar things a while ago, but these all looked like hardware failures or severely corrupted filesystems.

Could you please post the content of

/var/log/pakfire/update-core-upgrade-159.log

here (you can access this file from a live system as well, by mounting IPFire’s root partition), so we can see what went wrong exactly in your case?

Thanks, and best regards,
Peter Müller

1 Like

A post was split to a new topic: CPU frequency issues after upgrading to Core Update 159

My upgrade resulted in UEFI no longer booting, but legacy does boot. Looking at that log, it says:
Install GRUB on /dev/sda
Could not install GRUB on /dev/sda

and a couple of lines later: done

No other error or warning in the log.

Any pointer to fix this?

TIA Chris

Or perhaps there’s a way to re-apply the core update?

Hi,

and what does these couple of lines look like?

Not as such, but you can try to force a re-creation of the GRUB bootloader by running

/usr/bin/install-bootloader
grub-mkconfig -o /boot/grub/grub.cfg

(This is precisely what the upgrade script does, see here for its source code.)

Thanks, and best regards,
Peter Müller

1 Like

I don’t really remember, all I remember there was no hint of an error. Anyway. I ran the two commands and problem solved, UEFI is working again. I guess it was the install-bootloader that ran into trouble previously. But all is well, thnx.

Hi,

thanks for reporting back.

This is rather unsatisfying to read, since we do not know how to reproduce the error. :upside_down_face: Should this thing happen again and/or any new information arise, please let us know so we can investigate further.

Thanks, and best regards,
Peter Müller

I agree, as normally I don’t have issues like this when upgrading…

You asked about the couple of lines:

Found bootloader device: /dev/sda…
updating configuration…
Installing GRUB on /dev/sda…
Could not install GRUB on /dev/sda…
Generating grub configuration file …
Found background: /boot/grub/splash.png
Found linux image: /boot/vmlinuz-5.10.55-ipfire
Found initrd image: /boot/initramfs-5.10.55-ipfire.img
done

I’m assuming that the grub configuration was fine, as the legacy boot brought up a working ipfire, with all the stuff running well. So in reality the grub-mkconfig probably wasn’t needed and the install-bootloader is the one that failed. Perhaps there’s another log to check?

Rgds Chris

Is this only present with UEFI, or does this affect Legacy boot as well?

Hi,

according to OP, this only affects UEFI:

Thanks, and best regards,
Peter Müller