Entropy “Background service for random number generation” stopped


actually my 32bit system worked fine.
But I bought new hardware (Advantech SYS-2USM02 Atom D510) and installed 64Bit. Since then: Entropy “Background service for random number generation” stopped. Why? How can I start the service?


Hi Stefan (@icydney )

I suspect it means that the Atom D510 does not have RDRAND support. You can check on the System Information page. If RDRAND is supported then it will show up somewhere in the profile list.

Do you still get an Entropy graph. The entropy can be generated from a hardware source or from software or a combination. If you have the graph what level is it running at. I believe that as long as it is at or above 2k then there should not be a problem.

I didn’t find anything in the system information.
The entropy graphic is displayed, the value is over 3k

Then don’t worry about the random generator service not working. Mine is and my entropy is running at about 3.1k so your system is fine even without the RDRAND.

OK. Thank you for the information.

1 Like